HDU 1010 BFS

Tempter of the Bone



Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;  
'S': the start point of the doggie;  
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
在规定的步数走到门处,不能多也不能少,
1、当步数大于T是还没走完,
2、还需要的步数比理论最小距离还短
3、比理论上的最短距离多出来的必是偶数,奇数则错
这三个条件剪枝,提高效率...
#include <iostream>  
using namespace std;   

char map[8][8];
int visit[8][8];//记录是否走过
int dire[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//左右上下
int start_x,start_y,end_x,end_y;//起点终点
int step;//走的步数
int n,m,t;

bool bfs(int x,int y,int step)
{
	if(map[x][y]=='D'&&step==t)
		return true;
	if(x<1||x>m||y<1||y>n)
		return false;
	if(step>=t)
		return false;//剪枝1:当step>=t时还没有找到结点
	if((t-step)<(abs(x-end_x)+abs(y-end_y)))
		return false;//剪枝2:还需要的步数比理论最小距离还短
	if((t-step-(abs(x-end_x)+abs(y-end_y)))%2!=0)
		return false;//剪枝3:比理论上的最短距离多出来的必是偶数,奇数则错
	int i,xx,yy;
	for(i=0;i<4;i++)
	{
		xx=x+dire[i][0];
		yy=y+dire[i][1];
		if(xx>0&&xx<=m&&yy>0&&yy<=n&&map[xx][yy]!='X'&&visit[xx][yy]==0)
		{//判断是否越界、走过或撞墙
			visit[xx][yy]=1;
			if(bfs(xx,yy,step+1))
				return true;
			else
				visit[xx][yy]=0;
		}
	}
	return false;
}

int main()
{
	while (cin>>m>>n>>t&&(n||m||t))
	{
		int i,j;
		memset(visit,0,sizeof(visit));
		for(i=1;i<=m;i++)
		{
			for(j=1;j<=n;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='S')
					start_x=i,start_y=j;
				else if(map[i][j]=='D')
					end_x=i,end_y=j;
			}
		}
		visit[start_x][start_y]=1;
		bfs(start_x,start_y,0)?cout<<"YES":cout<<"NO";
		cout<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值