HDU 2473 并查集

Junk-Mail Filter

 

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 


 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 


 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 


 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 


 

Sample Output
  
  
Case #1: 3 Case #2: 2

 

并查集的删除

题意:

有那个信封

接收M a b 时,

说明a b是同一个种类

接收S a时

说明a放错位置

问一共有多少种类

并查集的删除

为每一个结点加一个虚根,

这样每个结点都是叶子结点.

插入结点时,

把它们都并到虚根的集合中.

删除结点时,

只要把它的父结点置为一个无用的虚根

#include <iostream>
#include <string>
using namespace std;
int p[2222222];
int s[1111111];
int find(int x)
{
	if(x!=p[x])
		p[x]=find(p[x]);
	return p[x];
}
void merge(int x,int y)
{
	p[find(x)]=find(y);
}
int main()
{
	int n,m,a,b,i,r=1;
	char str[11];
	while(scanf("%d%d",&n,&m)&&(n||m))
	{
		memset(s,0,sizeof(s));
		for(i=0;i<n;i++)
			p[i]=i+n;
		for(;i<2*n+m;i++)
			p[i]=i;
		int k=2*n;
		while(m--)
		{
			scanf("%s",str);
			if(str[0]=='M')
			{
				scanf("%d%d",&a,&b);
				merge(a,b);
			}
			else
			{
				scanf("%d",&a);
				p[a]=k++;
			}
		}
		int cnt=0;
		for(i=0;i<n;i++)
		{
			a=find(i);
			if(s[a]==0)
				cnt++,s[a]++;
		}
		printf("Case #%d: %d\n",r++,cnt);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值