hdu1160,FatMouse's Speed

9 篇文章 0 订阅

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9199    Accepted Submission(s): 4076
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 

Source
 

Recommend
Ignatius
 

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class HDU1160_ieayoio {
	public static F[] f;
	public static Mouse[] a;

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		a = new Mouse[1010];
		int k = 0;
		while (cin.hasNext()) {
			// for (int i=1;i<=9;i++){
			k++;//老鼠数
			a[k] = new Mouse(cin.nextInt(), cin.nextInt(), k);
		}
		//先将老鼠按重量从小到大排序,只要对排序后的老鼠对其速度用动态规划找到最长下降子序列就好了
		Arrays.sort(a, 1, k + 1, new cmp());
		a[0] = new Mouse(0, Integer.MAX_VALUE, 0);
		f = new F[k + 5];
		for (int i = 0; i < f.length; i++) {
			f[i] = new F(0, 0);
		}

		for (int i = 1; i <= k; i++)
			for (int j = 0; j <= i - 1; j++) {
				//a[i].size != a[j].size保证重量不等
				//若速度满足下降
				if (a[i].size != a[j].size && a[i].speed < a[j].speed) {
					if (f[j].max + 1 > f[i].max) {
						f[i].max = f[j].max + 1;//找到比f[i]更优的
						f[i].last = j;//记录上一个的编号
					}
				}
			}
		int maxi = 0, max = Integer.MIN_VALUE;
		for (int i = 1; i <= k; i++) {
			if (max < f[i].max) {
				max = f[i].max;//找到最长下降的位置
				maxi = i;//并记录编号
			}
		}
		System.out.println(f[maxi].max);
		ptf(maxi);//寻找并输出方案

	}

	static void ptf(int k) {
		if (k == 0)
			return;
		ptf(f[k].last);//递归找起始的老鼠
		System.out.println(a[k].index);//输出当前老鼠原本的标号 
	}

}

class cmp implements Comparator<Mouse> {

	@Override
	public int compare(Mouse o1, Mouse o2) {
		if (o1.size != o2.size) {
			return o1.size - o2.size;
		} else {
			return o2.speed - o1.speed;
		}
	}

}

class F {
	int max;//前i个老鼠的速度最长下降老鼠数
	int last;//上一个老鼠的编号

	F(int max, int last) {
		this.max = max;
		this.last = last;
	}
}

class Mouse {
	int size;//老鼠的重量
	int speed;//老鼠的速度
	int index;//老鼠原本的标号

	Mouse(int size, int speed, int index) {
		this.size = size;
		this.speed = speed;
		this.index = index;
	}
}


题目大意:

输入每行两个数,表示老鼠的重量和速度,需要找出所有老鼠中满足体重上升,速度下降的最长序列,输出最长序列数,并依次输出老鼠的标号


先将老鼠按重量从小到大排序,只要对排序后的老鼠对其速度用动态规划找到最长下降子序列就好了

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值