HDU-1160 FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing. 

Input


Input contains data for a bunch of mice, one mouse per line, terminated by end of file. 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. 

Two mice may have the same weight, the same speed, or even the same weight and speed. 

Output


Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]] 

and 

S[m[1]] > S[m[2]] > ... > S[m[n]] 

In order for the answer to be correct, n should be as large as possible. 
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

Sample Input


6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output


4
4
5
9
7

题目意思比较好理解,找一个最长的序列,序列要求是老鼠重量递增速度递减(严格),输出序列长度和路径。

这道题有点类似最长上升子序列,但是一个只要求元素上升不要求是子序列,一个要记录路径。第一个问题我们可以通过排序解决,第二个问题,可以通过一个链表数组pre来记录该节点之前的结点是什么。

要注意链表录完一遍以后是倒序的,要通过数组把顺序扳回来。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int dp[10010]={0},pre[10010]={0};
struct node
{
    int w,s,num;
}a[10010];
int cmp(const node &x,const node &y)
{
    if(x.w!=y.w)
        return x.w<y.w;
    return x.s>y.s;
}
int main()
{
    int i=1;
    while(~scanf("%d %d",&a[i].w,&a[i].s))
    {
        a[i].num=i;
        i++;
    }
    sort(a+1,a+i+1,cmp);

    int n=i;
    for(int i=1;i<n;i++)
    {
        pre[i]=i;
        dp[i]=1;
        for(int j=1;j<i;j++)
        {
            if(a[i].w!=a[j].w&&a[i].s<a[j].s)
            {
                if(dp[i]<dp[j]+1)
                {
                    pre[i]=j;
                    dp[i]=dp[j]+1;
                }
            }
        }
    }
    int maxx=0,index=0;
    for(int i=1;i<n;i++)
    {
        if(dp[i]>maxx)
        {
            maxx=dp[i];
            index=i;
        }
    }
    cout<<maxx<<endl;
    int out[10010]={0};
    i=0;
    while(pre[index]!=index)
    {
        out[i++]=a[index].num;
        index=pre[index];
    }
    cout<<a[index].num<<endl;
    for(int j=i-1;j>=0;j--)
        printf("%d\n",out[j]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值