FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
###Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

###Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

###Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

###Sample Output
4
4
5
9
7

###题目大意:
求在重量递减而速度递增的情况下的最大长度。并且输出这个顺序中每只老鼠的编号。

###解题思路:
基础DP问题最长上升子序列的一个小变形,我这里采用先按照重量递减排序后算最长速度下降的长度的做法。难点在于如何输出老鼠们的编号,也就是记录路径,智障的我想了半天,尝试结构体和二维数组储存都没有成功,后来在调试看输出时突然发现每只老鼠充当序列最大速度时对应的情况下长度是不一样的,存在一个递减顺序。又联系到dp数组保留了每种情况的最优解,通过最优解递推得到下一个最优解这句话,就拿样例来说,答案是4号老鼠开始的序列长度最大,其次实际上就是5号(3),9号(2),7号(1)(或者8号)。所以答案实际上都放在了dp数组中,利用循环判断,长度递减输出对于编号即可。
代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct mice
{
  int weight;
  int number;
  int speed;
}m[1010];
int cmp(mice a,mice b)
{
  if(a.weight==b.weight)return a.speed>b.speed;
  else return a.weight<b.weight;
}
int main()
{
  int weight,speed,j=0;
  while(scanf("%d %d",&weight,&speed)!=EOF)
  {
    m[j].weight=weight;
    m[j].speed=speed;
    m[j].number=j+1;
    j++;
  }
  sort(m,m+j,cmp);//按照重量递增排序
  int ma=0,num,dp[1010];
  for(int i=0;i<j;i++)dp[i]=1;//初始化,每只老鼠都做最大值,所在序列初始时仅有自己,故长度为1
  for(int i=j-1;i>=0;i--)
  {
    for(int k=i+1;k<j;k++)
    {
      if(m[k].weight>m[i].weight&&m[k].speed<m[i].speed)
      {
        dp[i]=max(dp[k]+1,dp[i]);
        if(dp[i]>ma) ma=dp[i];//更新最大的长度
      }
    }
  }
  cout<<ma<<endl;
  int temp=ma;
  for(int i=0;i<j;i++)
  {
    if(dp[i]==temp)
    {
      cout<<m[i].number<<endl;//分别输出序列长度递减的老鼠编号
      temp--;
    }
    if(!temp)break;
  }
  return 0;
}

又是一个独立解决的DP,不知为什么解决DP就很有成就感,可能是之前对这个问题太过回避不自信了吧。希望以后能对DP有所领悟,继续努力!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值