poj 1979 Red and Black(DFS)

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 22115 Accepted: 11919

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.  

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13



代码:
#include<cstring>
#include<cstdio>
#define MAXN 25

int n,m,count;
char grid[MAXN][MAXN];
int dir[4][2]={{0,-1},{0,1},{-1,0},{1,0}};//4个方向

int DFS(int x,int y)
{//深度搜索
    int xx,yy,i;
    grid[x][y]='#';
    for(i=0;i<4;i++)
    {
        xx=x+dir[i][0];
        yy=y+dir[i][1];
        if(xx>=0&&yy>=0&&xx<m&&yy<n&&grid[xx][yy]=='.')
        {
            count++;
            count=DFS(xx,yy);
        }
    }
    return count;
}

int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        for(i=0;i<m;i++)
            scanf("%s",grid[i]);
        count=1;
        for(i=0;i<m;i++)//注意:n列,m行
            for(j=0;j<n;j++)
                if(grid[i][j]=='@')
                {
                    count=DFS(i,j);
                    break;
                }
        printf("%d\n",count);
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值