Harmonious Contest

今天真的是要哭了,一天都没做什么事,晚上做了几道题目都是不过,最可恨的是有道队列的题目一直是输出错误,那么简单的输出我都不知道错在哪,今天没时间了,明天再看看吧,就找了一道水题做了,还是全英文的,要不是看输出还不知道意思,看样子是要学英语了。


描述

This is a magic country

Harmonious society

And harmonious people

This is a wonderful contest

Harmonious students

And harmonious problems.

This is the most harmonious problem, and the question is as following:

Given three positive integers A, B and C (0<A,B,C<=100) which denote the length of three edges, please tell me whether they can make up a legal triangle.

输入

The first line is an integer T(T<=100) which indicates the number of test cases.

Each test case consists of three integers A,B and C in a line.

输出

For each test case please output the type of triangle(Acute triangle、Right triangle or Obtuse triangle)if  A,B and C can make up a legal triangle, and output "NO" otherwise. One line per case.

样例输入

4
3 4 4
3 4 5
3 4 6
3 4 7

样例输出

Acute triangle
Right triangle
Obtuse triangle
NO

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
	int nl;
	cin>>nl;
	while(nl--)
	{
		int tp[3];
		cin>>tp[0]>>tp[1]>>tp[2];
		sort(tp,tp+3);//偷懒了,直接sort排序了
		if(tp[0]+tp[1]<=tp[2])
		{ cout<<"NO"<<endl; continue; };
		if(tp[0]*tp[0] + tp[1]*tp[1] == tp[2]*tp[2])
			cout<<"Right triangle"<<endl;
		else if(tp[0]*tp[0]+tp[1]*tp[1]>tp[2]*tp[2])
			cout<<"Acute triangle"<<endl;
		else
			cout<<"Obtuse triangle"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值