Harmonious

Harmonious

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 48   Accepted Submission(s) : 21
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

This is a magic country Harmonious society And harmonious people
This is a wonderful contest Harmonious students And harmonious problems.
This is the most harmonious problem, and the question is as following:
Given three positive integers A, B and C (0<A,B,C<=100) which denote the length of three edges, please tell me whether they can make up a legal triangle.

Input

The first line is an integer T(T<=100) which indicates the number of test cases.
Each test case consists of three integers A,B and C in a line.

Output

For each test case please output the type of triangle(Acute triangle、Right triangle or Obtuse triangle)if A,B and C can make up a legal triangle, and output "NO" otherwise. One line per case.

Sample Input

4
3 4 4
3 4 5
3 4 6
3 4 7

Sample Output

Acute triangle
Right triangle
Obtuse triangle
NO
#include <stdio.h>
#include <iostream>
using namespace std;
int main()
{
    int t,a,b,c;
     scanf("%d",&t);
        while (t--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if (a+b>c&&a+c>b&&b+c>a)
            {
                if (a*a+b*b==c*c||a*a+c*c==b*b||b*b+c*c==a*a)
                {
                    printf ("Right triangle\n");
                }
                else if   (b*b+c*c-a*a>0&&a*a+b*b-c*c>0&&a*a+c*c-b*b>0)
                {
                    printf("Acute triangle\n");
                }
                else
                    printf("Obtuse triangle\n");
            }
            else
                printf("NO\n");
        }




    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值