HDU4493 UVA 465 sscanf和sprintf的使用

HDU4493:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4493

题目描述:

Tutor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1544    Accepted Submission(s): 431


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
  
  
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
  
  
$1581.42 $100
 

Source

题目大意:求12个数的平均数,结果没有后缀0。

题解:结果要求四舍五入且去掉末尾的0,所以用sprintf转换成字符串形式处理比较方便。

代码:

/**
 * @author neko01
 */
#include <iostream>
#include <cstdio>
#include <string.h>
#include <cstring>
using namespace std;
int main()
{
    int t;
    double a[13];
    scanf("%d",&t);
    while(t--)
    {
        double sum=0;
        char s[15];
        for(int i=0;i<12;i++)
        {
            scanf("%lf",&a[i]);
            sum+=a[i];
        }
        sum=sum/12;
        sprintf(s,"%.2lf",sum);
        int l=strlen(s);
        if(s[l-1]=='0'&&s[l-2]=='0')
            s[l-3]='\0';
        else if(s[l-1]=='0')
            s[l-1]='\0';
        printf("$%s\n",s);
    }
    return 0;
}
UVA465

题目链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=406

题目大意:判断加法或乘法的因子和结果与是否大于int

题解:以字符串形式输入,然后用sscanf转换成double型进行比较

代码:

/**
 * @author neko01
 */
#include <iostream>
#include <cstdio>
#include <stdlib.h>
using namespace std;
long long INF=2147483647;
char s1[1000];
char s2[1000];
char c;
int main()
{
    while(scanf("%s %c %s",s1,&c,s2)!=EOF)
    {
	double a,b;
	sscanf(s1,"%lf",&a);
        sscanf(s2,"%lf",&b);;
        printf("%s %c %s\n",s1,c,s2);
        if(a>INF)
        printf("first number too big\n");
        if(b>INF)
        printf("second number too big\n");
        if(c=='+')
        {
            if(a+b>INF)
            printf("result too big\n");
        }
        if(c=='*')
        {
            if(a*b>INF)
            printf("result too big\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值