UVa 10014 Simple calculations

d

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1150.5025.5010.15

Sample Output

27.85

给跪了。。。推公式,其实早就推出来了,但是没有看题目要求要就输出a[1],结果一直在化简。。。处于不知道在求什么的状态。。。

代码如下:

#include <stdio.h>
int main(void)
{
    int cases,n,i,j;
    double a,b,c[3002],sum;
    scanf("%d\n",&cases);
    while(cases--)
    {
     scanf("%d",&n);
     scanf("%lf\n",&a);
     scanf("%lf",&b);
     for(i=1;i<=n;i++)
      scanf("%lf",&c[i]);
     sum=0.0;
     for(i=1;i<n+1;i++)
      for(j=1;j<=i;j++)
       sum+=c[j];
     sum*=2;
     a=(n*a+b-sum)/(n+1.0);
     printf("%4.2f\n",a);  
     if(cases)
      printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值