HDU 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23264    Accepted Submission(s): 9443


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

Author
Teddy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1203  2159  2955  1171  2191 
 


典型的01背包题目,说实话我是看了别人的算法模板的,还不是很理解,明天接着刷类似的题目吧,期待会有所领会。
代码如下:
#include <stdio.h>
#include <string.h>
#define rep(i,k,n) for(int i=(k); i<(n); i++)
#define cls(x,a) memset(x,a,sizeof(x))
#define maxn 10010

int a[maxn],b[maxn];

int main(void){
    int n,m,t;
    int dp[maxn];
    scanf("%d",&t);
    rep(i,0,t){
     scanf("%d%d",&n,&m);
     rep(i,0,n) scanf("%d",&a[i]);
     rep(i,0,n) scanf("%d",&b[i]);
     cls(dp,0);
     rep(i,0,n)
      for(int j=m; j>=b[i]; j--){
       if (dp[j]<dp[j-b[i]]+a[i])
        dp[j] = dp[j-b[i]]+a[i];
      }
     printf("%d\n",dp[m]);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值