UVa 409 - Excuses, Excuses!

Excuses, Excuses! 

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data.

  • Line 1 of each set will contain exactly two integers. The first number ( tex2html_wrap_inline30 ) defines the number of keywords to be used in the search. The second number ( tex2html_wrap_inline32 ) defines the number of excuses in the set to be searched.
  • Lines 2 through K+1 each contain exactly one keyword.
  • Lines K+2 through K+1+E each contain exactly one excuse.
  • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( tex2html_wrap_inline42 ) and will occupy columns 1 through L in the input line.
  • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
  • Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list.

  • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
  • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
  • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!
 
逗比了,写出来后提交一直Runtime Error
后来百度知道自己错在哪了。。。
我读取一行借口时,是逐次读入字符直到出现‘\n’
但是输入借口的最后一行可能没有‘\n’
最逗比的是我一直用这种方法读取含空格的字符串
忘了初学C时的gets(),我对不起C语言老师啊大哭
代码如下:
连续注释的地方就是之前出错的地方
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#define MAXN 100
#define INF 0x7FFFFFFF
#define ll long long
using namespace std;
int main(void){
	int K, E;
	int I = 0;//表示set次数 
	while(scanf("%d %d", &K, &E) != EOF){
		char words[MAXN][MAXN] = {};
		char str[MAXN][MAXN] = {};
		char worst[MAXN][MAXN] = {}; 
		for(int i=0; i<K; ++i){
			scanf("%s", words[i]);
		}
		getchar();//处理输入单词后最后一个换行 
		for(int i=0; i<E; ++i){
			gets(str[i]);
//			char ch;
//			int j = 0;
//			ch = getchar();
//			while(ch != '\n'){
//				str[i][j++] = ch;
//				scanf("%c", &ch);
//			}
//			str[i][j] = '\0';
		}
		
		//找到每个借口中words出现次数
		int incidence = 0;//表示当前所有借口中words出现最多次数 
		int T = 0;
		int times = 0;
		for(int i=0; i<E; ++i){
			
			int len = strlen(str[i]);
			char str1[MAXN] = {};//存储从借口中取出的单词 
			int j = 0;
			times = 0; 
			
			while(j < len){//取出借口中所有单词并与所有的关键字匹配 
				int k = 0;
				while(isalpha(str[i][j])){
					str1[k++] = tolower(str[i][j++]);
				}
				while(!isalpha(str[i][j]))
					++j;//处理掉非字母字符 
				str1[k] = '\0';
				//找到借口中关键词匹配次数 
				
				for(int flag=0; flag<K; ++flag){
					if(strcmp(str1, words[flag]) == 0){
						times++;
					}
				}
			}
		
			if(times > incidence){
				strcpy(worst[T], str[i]);
				incidence = times; 
			} 
			else if(times == incidence){
				strcpy(worst[++T], str[i]);
			}
 	    }
 	    
 	    ++I;
 	    cout << "Excuse Set #" << I << endl;
		for(int i=0; i<=T; ++i){
 	    	cout << worst[i] << endl;	
 	    }
 	    cout << endl;
	} 

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值