Excuses, Excuses!

Description

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data. Line 1 of each set will contain exactly two integers. The first number (1 <= K <= 20) defines the number of keywords to be used in the search. The second number (1 <= E <= 20) defines the number of excuses in the set to be searched. Lines 2 through K+1 each contain exactly one keyword. Lines K+2 through K+1+E each contain exactly one excuse. All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (1 <= L <= 20) and will occupy columns 1 through L in the input line. All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [".,!?] not including the square brackets and will not exceed 70 characters in length. Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list. The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords. If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword "occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space. 

For each set of input, you are to print a single line with the number of the set immediately after the string "Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order. After each set of output, you should print a blank line. 

Sample Input

题意:给出n给单词(小写),再给出m个句子,输出包含单词最多的句子(不区分大小写),有并列的话按输入顺序输出

如第一个测试样例第一个句子包含dog,ate,homework三个单词,第二个句子包含dog,died,canary,homework(因为不区分大小写,所以大写的HOMEWORK也算一个)四个句子,注意,句子中重复出现的单词也要上,也就是说重复出现的不能只算一次,而是出现几次就算几次

因为数组开小了,一直出现Runtime Error 错误提示,一开始怎么也找不出来,弄了一下午,百度搜一下Runtime Error到底有哪些错误,才发现数组小了,坑啊,改了之后,终于AC了,心累大哭大哭大哭

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!
#include<cstdio>
#include<cctype>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
char a[21][21];
char b[21][101];
int A(char str[],int x)
{
    for(int i=0; i<x; i++)
    {
        if(strcmp(str,a[i])==0)
            return 1;
    }
    return 0;
}
int main()
{
    int n,m,k,maxx,ans[21],Case=1;
    char temp[100];//一开始只开了个21,一直Runtime Error,欲哭无泪
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        getchar();
        maxx=-1;
        memset(ans,0,sizeof(ans));
        for(int i=0; i<n; i++)
            gets(a[i]);
        //getchar();
        for(int i=0; i<m; i++)
        {
            gets(b[i]);
            int len=strlen(b[i]);
            for(int j=0; j<len;)
            {
                k=0;
                while(j<len&&isalpha(b[i][j]))
                {
                    temp[k++]=tolower(b[i][j]);
                    j++;
                }
                j++;
                temp[k]='\0';
                if(A(temp,n))
                    ans[i]++;
            }
            if(maxx<ans[i])
                maxx=ans[i];
        }
        printf("Excuse Set #%d\n",Case);
        Case++;
        for(int i=0; i<m; i++)
        {
            if(maxx==ans[i])
                puts(b[i]);
        }
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值