POJ 1068 Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18818 Accepted: 11341

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

今天下午做的郑州ACM练习赛的第一题,别人分分钟就A了。。。
我却用了很久,会的题不能很快做出来!这就是缺陷
给出的数据是对应每个右括号左侧出现左括号的个数
要求输出每个右括号匹配后内部所含匹配括号数(含自身)
我的思路是现根据给出的数据得出所有括号,再统计
期间跪了一次,是因为在上组测试数据中用过的数组在这次中未初始化!!
代码如下:
#include <map>
#include <cmath>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define esp 1e-9
#define MAXN 10010
#define ll long long
#define INF 0x7FFFFFFF
#define BUG system("pause")
#define SW(a,b) a^=b;b^=a;a^=b;
using namespace std;
int a[MAXN];
int flag[MAXN];
int b[MAXN];
int main(void){
	int T;
	cin >> T;
		while(T--){
			int n;
			string str;
			cin >> n;
			for(int i=0; i<1000; ++i){
				flag[i] = 0;
				b[i] = 0;
			}
			for(int i=0; i<n; ++i){
				cin >> a[i]; 
			}
			
			int t = 0;
			for(int i=0; i<a[0]; ++i){
				str.push_back('(');
			}
			str.push_back(')');
			for(int i=1; i<n; ++i){
				int k = a[i]-a[i-1];
				while(k--){
					str.push_back('(');
				}
				str.push_back(')');
			}
//			cout << "str = " << str << endl;
			for(int i=0; i<str.size(); ++i){
				if(str[i] == ')'){
					for(int j=i-1; j>=0; --j){
						if(str[j]=='(' && flag[j]==0){
							flag[j] = 1;
							b[t++] = (i-j)/2+1;
							break;
						}
					}
				}
			}
			for(int i=0; i<n-1; ++i){
				cout << b[i] << " ";
			}
			cout << b[n-1] << endl; 
		}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值