UVa 673 Parentheses Balance


  Parentheses Balance 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct,  () and  [] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer  n  and a sequence of  n  strings of parentheses  ()  and  [] , one string a line.

Output 

A sequence of  Yes  or  No  on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes

括号匹配,很水的题,直接上代码:

#include <stdio.h>
#include <string.h>
int main(void)
{
    int n,i,count,len;
    char s[130];
    char stack[130];
    
    scanf("%d",&n);
    getchar();
    while(n--)
    {
     gets(s);
     if(!strlen(s))
     {
      printf("Yes\n");
      continue;
     }
     stack[0]=s[0];
     count=0;
     for(i=1;i<strlen(s);i++)
     {
      len=s[i]-stack[count];
      if(len==1||len==2)
       count--;
      else
      {
       count++;
       stack[count]=s[i];      
      }
     }
     if(count==-1) printf("Yes\n");
     else printf("No\n");
    } 
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值