poj1743 Musical Theme 二分+后缀数组



Language:
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17395 Accepted: 5983

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.

Source



题意:有N个(1<=N<=20000)个音符的序列来表示一首乐曲,每个音符都是1到88范围内的整数,现在要找一个重复的主题。“主题”是整个音符序列的一个子串,他需要满足如下条件:
1.长度至少为5个音符
2.在乐曲中重复出现(可能经过转调,“转调”的意思是主题序列中每个音符都被加上或减去一个同一个整数值)
3.重复出现的同一主题不能有公共部分。

思路:求出任意相邻音符的差值,然后把问题转化为求不可重叠最长重复子串,用后缀数组来做。二分答案,把问题变成判定行为题:判断是否存在两个长度为k的子串是相同的,且不重叠。利用height数组,把排序后的后缀分成若干组,其中每组的后缀之间的height值都不小于k。容易看出,有希望成为最长公共前缀不小于k的两个后缀一定在同一组。然后对于每组后缀,值需判断每个后缀的sa值的最大值和最小值之差时候不小于k。如果有一组满足,则说明存在,否则不存在。时间复杂度为O(nlogn)。详见代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=20000+100;
int n;
int a[MAXN],t1[MAXN],t2[MAXN],c[MAXN],sa[MAXN],rank[MAXN],height[MAXN];
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b] && r[a+l]==r[b+l];
}
void build_sa(int m)
{
    int i,k,p=0;
    int *x=t1,*y=t2;
    for(i=0;i<m;i++) c[i]=0;
    for(i=0;i<n;i++) c[x[i]=a[i]]++;
    for(i=1;i<m;i++) c[i]+=c[i-1];
    for(i=n-1;i>=0;i--) sa[--c[x[i]]]=i;
    for(k=1;p<n;k<<=1,m=p)
    {
        for(p=0,i=n-k;i<n;i++) y[p++]=i;
        for(i=0;i<n;i++) if(sa[i]>=k) y[p++]=sa[i]-k;
        for(i=0;i<m;i++) c[i]=0;
        for(i=0;i<n;i++) c[x[y[i]]]++;
        for(i=1;i<m;i++) c[i]+=c[i-1];
        for(i=n-1;i>=0;i--) sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        for(p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],k)? p-1:p++;
    }
}
void calheight(int n)
{
    int k=0;
    for(int i=1;i<=n;i++) rank[sa[i]]=i;
    for(int i=0;i<n;i++)
    {
        if(k) k--;
        int j=sa[rank[i]-1];
        while(a[i+k]==a[j+k]) k++;
        height[rank[i]]=k;
    }
}
bool ok(int n,int k)
{
    int l=sa[1],r=sa[1];
    for(int i=2;i<=n;i++)
        if(height[i]<k)
            l=r=sa[i];
        else
        {
            if(sa[i]<l) l=sa[i];
            if(sa[i]>r) r=sa[i];
            if(r-l>=k)
                return 1;
        }
    return 0;
}
int main()
{
    freopen("text.txt","r",stdin);
    while(~scanf("%d",&n) && n)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n-1;i++)
            a[i]=(a[i]-a[i+1])+100;
        a[n-1]=0;
        build_sa(200);
        calheight(n-1);
        int l=1,r=n/2,ans=0;
        while(l<=r)
        {
            int mid=(l+r)>>1;
            if(ok(n-1,mid))
                ans=mid,l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n",ans>=4? ans+1:0);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值