POJ 1743 Musical Theme 后缀数组+二分

http://poj.org/problem?id=1743
A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1…88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings.
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it:
is at least five notes long
appears (potentially transposed – see below) again somewhere else in the piece of music
is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence.
Given a melody, compute the length (number of notes) of the longest theme.
One second time limit for this problem’s solutions!
Input
The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes.
The last test case is followed by one zero.
Output
For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.
Sample Input
30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0
Sample Output
5
Hint
Use scanf instead of cin to reduce the read time.
题目大意:找出序列中不重叠的两个子串,它们的变化趋势是相同的,比如 1 , 2 , 3 , 4 , 5 1,2,3,4,5 1,2,3,4,5 6 , 7 , 8 , 9 , 10 6,7,8,9,10 6,7,8,9,10,输出这样的子串的最大长度。
思路:题目变形后就是找不可重叠最长重复子串的最大长度。对原序列进行差分,仍以上面的序列为例,我们得到了新序列: 1 , 1 , 1 , 1 , 1 1,1,1,1,1 1,1,1,1,1 1 , 1 , 1 , 1 , 1 1,1,1,1,1 1,1,1,1,1,显然不可重叠的最长重复子串的最大长度就是5,而正解也是5。那么怎么得到这个长度呢,我们可以二分来判断。对于当前要判断的长度 m i d mid mid,在 h e i g h t height height数组中找到连续的一段且值 &gt; = m i d &gt;=mid >=mid的区间,判断这个区间内 s a sa sa的最大值减去最小值是否 &gt; m i d &gt;mid >mid即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 20010
using namespace std;
int s[maxn];
int y[maxn],x[maxn],c[maxn],sa[maxn],rk[maxn],height[maxn];
int n,m;

inline void get_SA()
{
    for(int i=1;i<=n;++i) ++c[x[i]=s[i]];
	//c数组是桶
	//x[i]是第i个元素的第一关键字
    for(int i=2;i<=m;++i) c[i]+=c[i-1]; //m 输入字符串的 ASCII 上限
	//做c的前缀和,我们就可以得出每个关键字最多是在第几名 计数排序的思想
    for(int i=n;i>=1;--i) sa[c[x[i]]--]=i;
    for(int k=1;k<=n;k<<=1)
	{
        int num=0;
        for(int i=n-k+1;i<=n;++i) y[++num]=i;
		//y[i]表示第二关键字排名为i的数,第一关键字的位置
		//第n-k+1到第n位是没有第二关键字的 所以排名在最前面 要先处理
        for(int i=1;i<=n;++i) if(sa[i]>k) y[++num]=sa[i]-k;
		//排名为i的数 在数组中是否在第k位以后
		//如果满足(sa[i]>k) 那么它可以作为别人的第二关键字,就把它的第一关键字的位置添加进y就行了
		//所以i枚举的是第二关键字的排名,第二关键字靠前的先入队
        for(int i=1;i<=m;++i) c[i]=0;
		//初始化c桶
        for(int i=1;i<=n;++i) ++c[x[i]];
		//因为上一次循环已经算出了这次的第一关键字 所以直接加就行了
        for(int i=2;i<=m;++i) c[i]+=c[i-1]; //第一关键字排名为1~i的数有多少个
        for(int i=n;i>=1;--i) sa[c[x[y[i]]]--]=y[i],y[i]=0;
		//因为y的顺序是按照第二关键字的顺序来排的
		//第二关键字靠后的,在同一个第一关键字桶中排名越靠后
		//基数排序
        swap(x,y);
		//这里不用想太多,因为要生成新的x时要用到旧的,就把旧的复制下来,没别的意思
        x[sa[1]]=1;
        num=1;
        for(int i=2;i<=n;++i)
            x[sa[i]]=(y[sa[i]]==y[sa[i-1]] && y[sa[i]+k]==y[sa[i-1]+k]) ? num:++num;
		//因为sa[i]已经排好序了,所以可以按排名枚举,生成下一次的第一关键字
        if(num==n) break;
        m=num;
		//这里就不用那个m了,因为都有新的编号了
    }
}
inline void get_height()
{
    int k=0;
    for(int i=1;i<=n;++i) rk[sa[i]]=i;
    for(int i=1;i<=n;++i)
	{
        if(rk[i]==1) continue;//第一名height为0
        if(k) --k;//h[i]>=h[i-1]-1;
        int j=sa[rk[i]-1];
        while(j+k<=n&&i+k<=n&&s[i+k]==s[j+k]) ++k;
        height[rk[i]]=k;//h[i]=height[rk[i]];
    }
}

bool check(int x)
{
	int MAX=0,MIN=2e4;
	for(int i=2;i<=n;i++)
	{
		if(height[i]>=x)
		{
			MAX=max(MAX,max(sa[i],sa[i-1]));
			MIN=min(MIN,min(sa[i],sa[i-1]));
			if(MAX-MIN>x)
				return 1;
		}
		else
			MAX=0,MIN=2e4;
	}
	return 0;
}

int main()
{
	while(~scanf("%d",&n)&&n)
	{
		for(int i=1;i<=n;i++)
			scanf("%d",&s[i]);
		if(n<10)
		{
			printf("0\n");
			continue;
		}
		m=200;
		memset(c,0,sizeof(c));
		for(int i=n;i>=1;i--)
			s[i]=s[i]-s[i-1]+100;
		get_SA();
		get_height();
		int l=1,r=n,mid;
		while(l<=r)
		{
			mid=l+r>>1;
			if(!check(mid))
				r=mid-1;
			else
				l=mid+1;
		}
		if(r>=4)
			printf("%d\n",r+1);
		else
			printf("0\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值