poj3261Milk Patterns 二分+后缀数组



Language:
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 9665 Accepted: 4333
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers:  N and  K 
Lines 2.. N+1:  N integers, one per line, the quality of the milk on day  i appears on the  ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least  K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source


Language:

题意:给定一个字符串,求至少出现k次的最长重复子串,这k个子串可以重叠。
思路:二分答案,利用height数组,将后缀分成若干组,判断是否存在一个组的后缀个数不小于k,如果存在那么存在k个相同的子串满足条件。时间复杂度为O(nlogn),详见代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=20000+100;
const int M=1000010;
int n,K;
int a[MAXN],sa[MAXN],height[MAXN],c[M],rank[MAXN],t1[MAXN],t2[MAXN];
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b] && r[a+l]==r[b+l];
}
void build_sa(int m)
{
    int i,k,p=0;
    int *x=t1,*y=t2;
    for(i=0;i<m;i++) c[i]=0;
    for(i=0;i<n;i++) c[x[i]=a[i]]++;
    for(i=1;i<m;i++) c[i]+=c[i-1];
    for(i=n-1;i>=0;i--) sa[--c[x[i]]]=i;
    for(k=1;p<n;k<<=1,m=p)
    {
        for(p=0,i=n-k;i<n;i++) y[p++]=i;
        for(i=0;i<n;i++) if(sa[i]>=k) y[p++]=sa[i]-k;
        for(i=0;i<m;i++) c[i]=0;
        for(i=0;i<n;i++) c[x[y[i]]]++;
        for(i=1;i<m;i++) c[i]+=c[i-1];
        for(i=n-1;i>=0;i--) sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        for(p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],k)? p-1:p++;
    }
}
bool ok(int n,int m)
{
    int cnt=1;
    for(int i=1;i<=n;i++)
    {
        if(height[i]>=m)
        {
            cnt++;
            if(cnt>=K)
                return 1;
        }
        else
            cnt=1;
    }
    return 0;
}
void calheight(int n)
{
    int k=0;
    for(int i=1;i<=n;i++) rank[sa[i]]=i;
    for(int i=0;i<n;i++)
    {
        if(k) k--;
        int j=sa[rank[i]-1];
        while(a[i+k]==a[j+k]) k++;
        height[rank[i]]=k;
    }
}
int main()
{
    //freopen("text.txt","r",stdin);
    while(~scanf("%d%d",&n,&K))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]),a[i]++;
        a[n++]=0;
        build_sa(1000010);
        calheight(n-1);
        int l=1,r=n-1,ans=0;
        while(l<=r)
        {
            int mid=(l+r)>>1;
            if(ok(n-1,mid))
                ans=mid,l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值