hdu3652 B-number 数位dp

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2282    Accepted Submission(s): 1239


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
 

Author
wqb0039
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3651  3655  3654  3653  3659 
 
题意:找1-n之间包含13且能被13整除的数的个数。

思路:设dp[pos][mod][s]表示当前访问到pos位,即第(pos+1)位时(从0开始的),pos位之前位的余为mod、状态为s,这(pos+1)个数位与之前位的组合可以满足包含13

且能被13整除的个数。s=0,表示之前没有出现13;s=1,表示之前没有出现13,但pos+1位是1;s=2,表示之前出现过13。详见代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=15;
int n;
int bit[MAXN],dp[MAXN][MAXN][5];
int dfs(int pos,int s,int flag,int mod)
{
    if(pos == -1) return mod == 0 && s==2; //出现13且能被整除
    if(flag && dp[pos][mod][s]!=-1) return dp[pos][mod][s];
    int ans=0;
    int x=flag ? 9 : bit[pos];
    for(int i=0;i<=x;i++){
        int k=(mod*10+i)%13;
        if(s==2 || (s == 1 && i == 3 ) ) ans+=dfs(pos-1,2,flag || i<x,k);
        else if(i == 1) ans+=dfs(pos-1,1,flag || i<x,k);
        else  ans+=dfs(pos-1,0,flag || i<x ,k);
    }
    if(flag) dp[pos][mod][s]=ans;
    return ans;
}
int solve(int x)
{
    int len=0;
    while(x){
        bit[len++]=x%10;
        x/=10;
    }
   return dfs(len-1,0,0,0);
}
int main()
{
    //freopen("text.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        memset(dp,-1,sizeof(dp));
        printf("%d\n",solve(n));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值