hdu 4927 Series 1 递推+大数

Series 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Let A be an integral series {A 1, A 2, . . . , A n}. The zero-order series of A is A itself. The first-order series of A is {B 1, B 2, . . . , B n-1},where B i = A i+1 - A i. The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1). Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 

Input
  
  
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10). For each test case: The first line contains a single integer n(1<=n<=3000), which denotes the length of series A. The second line consists of n integers, describing A 1, A 2, . . . , A n. (0<=A i<=10 5)
 

Output
  
  
For each test case, output the required integer in a line.
 

Sample Input
  
  
2 3 1 2 3 4 1 5 7 2
 

Sample Output
  
  
0 -5
 



import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main{
		public static void main(String arg[]){
		final int MAXN=3000+100;
		Scanner cin=new Scanner(System.in);
		BigInteger[] a=new BigInteger[MAXN];
		BigInteger[] c=new BigInteger[MAXN];
		int T;
		T=cin.nextInt(); 
		while(T>0){
			T--;
			int n;
			n=cin.nextInt();
			c[0]=BigInteger.ONE;
			for(int i=1;i<=n;i++){
				c[i]=(c[i-1].multiply(BigInteger.valueOf(n-i)));
				c[i]=c[i].divide(BigInteger.valueOf(i));
			}
			for(int i=1;i<=n;i++){
				a[i]=cin.nextBigInteger();
			}
			BigInteger ans=BigInteger.ZERO;
			for(int i=1;i<=n;i++){
				if(i%2 == 1)
					ans=ans.add(c[i-1].multiply(a[n+1-i]));
				else 
					ans=ans.subtract(c[i-1].multiply(a[n+1-i]));
			}
			System.out.println(ans);
		}
	}
};


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值