PAT甲级真题及训练集(16)--1032. Sharing (25)

1032. Sharing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

提交代

/**
作者:一叶扁舟
时间:16:58 2017/7/1
思路:
*/
#include <stdio.h>
#include <stdlib.h>

#define SIZE 100001
typedef struct SList{
	//char data;//数据域,如果添加这个我的vs2013编译器内存溢出,因为100001* 8,反正又没用到这个数据,就注释掉了
	int next;//下一个数据的地址,对应着数组的小标
	bool flag;//标记是否在链表中出现过

}SList;
int main(){
	SList sList[SIZE];
	int address, next;//
	char data;
	int N;//要输入的数据的长度
	int firstAddress;//链表开始的首地址jisuan
	int secondAddress;//第二个链表的开始地
	scanf("%d %d %d", &firstAddress, &secondAddress, &N);


	//1.获取输入数据,地址对应着下标
	for (int i = 0; i < N; i++){
		scanf("%d %c %d", &address, &data, &next);
		//sList[address].data = data;
		sList[address].next = next;
		sList[address].flag = false;
	}
	//2.将链表串起来
	int i = firstAddress;//首地址
	while (i != -1){
		sList[i].flag = true;//在链表1中出现过
	
		if (sList[i].next == -1){//说明到链表末尾
			break;
		}
		
	
		i = sList[i].next;
	}


	//查询链表2中和链表1中重复的结点
	int second = secondAddress;//首地址
	while (second != -1){
		if (sList[second].flag == true){
			printf("%05d", second);
			return 0;
		}
		if (sList[second].next == -1){//说明到链表末尾
			printf("-1");
			return 0;
		}
		second = sList[second].next;
	}

	//注意,如果不在最后面添加这个判断,pat总是有一个无法通过,可能存在一组第一个就是空的吧(其实我添加了一个return 0足以解决后面的输出问题
	//事实上不管用,只能猜测second 一开始就为-1,即第二个链表为空)
	if (second != -1){
		printf("%05d", second);
	}
	else{
		printf("-1");
	}
	system("pause");
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值