hdu4737 A Bit Fun (2013 网络赛 成都赛区)

A Bit Fun

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 71    Accepted Submission(s): 37


Problem Description
There are n numbers in a array, as a 0, a 1 ... , a n-1, and another number m. We define a function f(i, j) = a i|a i+1|a i+2| ... | a j . Where "|" is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

Input
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2 30) Then n numbers come in the second line which is the array a, where 1 <= a i <= 2 30.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1.
Then follows the answer.
 

Sample Input
  
  
2 3 6 1 3 5 2 4 5 4
 

Sample Output
  
  
Case #1: 4 Case #2: 0
 
枚举 
#include <iostream>

using namespace std;

#define MAXN 100001

int temp[MAXN];

void input()
{
    int t;
    int n, m, k = 0;
    cin >> t;

    while (t--)
    {
        long long ans = 0;

        cin >> n >> m;

        for (int i = 0; i < n; i++)
        {
            cin >> temp[i];
        }

        for (int i = 0; i < n; i++)
        {
            int tmp = 1;

            for (int j = i; j < n; j++)
            {
                tmp |= temp[j];
                if (tmp < m)
                {
                    ans++;
                }
                else
                {
                    break;
                }
            }
        }
        cout << "Case #" << ++k << ": ";
        cout << ans << endl;
    }
}

int main()
{
    std::ios::sync_with_stdio(false);
    input();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值