hdu 4731 Minimum palindrome(网络赛 成都赛区)

Minimum palindrome

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 72    Accepted Submission(s): 26


Problem Description
Setting password is very important, especially when you have so many "interesting" things in "F:\TDDOWNLOAD".
We define the safety of a password by a value. First, we find all the substrings of the password. Then we calculate the maximum length of those substrings which, at the meantime, is a palindrome.
A palindrome is a string that will be the same when writing backwards. For example, aba, abba,abcba are all palindromes, but abcab, abab are not.
A substring of S is a continous string cut from S. bcd, cd are the substrings of abcde, but acd,ce are not. Note that abcde is also the substring of abcde.
The smaller the value is, the safer the password will be.
You want to set your password using the first M letters from the alphabet, and its length should be N. Output a password with the smallest value. If there are multiple solutions, output the lexicographically smallest one.
All the letters are lowercase.
 

Input
The first line has a number T (T <= 15) , indicating the number of test cases.
For each test case, there is a single line with two integers M and N, as described above.(1 <= M <= 26, 1 <= N <= 10 5)
 

Output
For test case X, output "Case #X: " first, then output the best password.
 

Sample Input
  
  
2 2 2 2 3
 

Sample Output
  
  
Case #1: ab Case #2: aab
 
#include <iostream>
#include <string>

using namespace std;

string ans[9]={"","a","ab","aab","aabb","aaaba","aaabab","aaababb","aaababbb"};

void input()
{
    int t, n, m, k = 0;

    cin >> t;

    while (t--)
    {
        cin >> m >> n;

        cout << "Case #" << ++k << ": ";

        if (m == 1)
        {
            for (int i = 0; i < n; i++)
            {
                cout << 'a';
            }
        }
        else if (m > 2)
        {
            for (int i = 0; i < n / 3; i++)
            {
                cout << "abc";
            }

            if (n % 3 == 1)
            {
                cout << "a";
            }
            else if (n % 3 == 2)
            {
                cout << "ab";
            }
        }
        else
        {
            if (n <= 8)
            {
                cout << ans[n];
            }
            else
            {
                cout << "aa";
                n -= 2;

                for (int i = 0; i < n / 6; i++)
                {
                    cout << "aababb";
                }

                if (n % 6 == 1)
                {
                    cout << "a";
                }
                else if (n % 6 == 2)
                {
                    cout << "aa";
                }
                else if (n % 6 == 3)
                {
                    cout << "aaa";
                }
                else if (n % 6 == 4)
                {
                    cout << "aaaa";
                }
                else if (n % 6 == 5)
                {
                    cout << "aabab";
                }
            }
        }
        cout << endl;
    }
}

int main()
{
    std::ios::sync_with_stdio(false);
    input();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值