ACM-> 二分图的最优匹配

Similarity
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

When we were children, we were always asked to do the classification homework. For example, we were given words {Tiger, Panda, Potato, Dog, Tomato, Pea, Apple, Pear, Orange, Mango} and we were required to classify these words into three groups. As you know, the correct classification was {Tiger, Panda, Dog}, {Potato, Tomato, Pea} and {Apple, Pear, Orange, Mango}. We can represent this classification with a mapping sequence{A,A,B,A,B,B,C,C,C,C}, and it means Tiger, Panda, Dog belong to group A, Potato, Tomato, Pea are in the group B, and Apple, Pear, Orange, Mango are in the group C.
But the LABEL of group doesn't make sense and the LABEL is just used to indicate different groups. So the representations {P,P,O,P,O,O,Q,Q,Q,Q} and {E,E,F,E,F,F,W,W,W,W} are equivalent to the original mapping sequence. However, the representations {A,A,A,A,B,B,C,C,C,C} and
{D,D,D,D,D,D,G,G,G,G} are not equivalent.



The pupils in class submit their mapping sequences and the teacher should read and grade the homework. The teacher grades the homework by calculating the maximum similarity between pupils' mapping sequences and the answer sequence. The definition of similarity is as follow. 

Similarity(S, T) = sum(S i == T i) / L 
L = Length(S) = Length(T), i = 1, 2,... L,
where sum(S i == T i) indicates the total number of equal labels in corresponding positions. The maximum similarity means the maximum similarities between S and all equivalent sequences of T, where S is the answer and fixed. Now given all sequences submitted by pupils and the answer sequence, you should calculate the sequences' maximum similarity.
 

Input

The input contains multiple test cases. The first line is the total number of cases T (T < 15). The following are T blocks. Each block indicates a case. A case begins with three numbers n (0 < n < 10000), k (0 < k < 27), m (0 < m < 30), which are the total number of objects, groups, and students in the class. The next line consists of n labels and each label is in the range [A...Z]. You can assume that the number of different labels in the sequence is exactly k. This sequence represents the answer. The following are m lines, each line contains n labels and each label also is in the range [A...Z]. These m lines represent the m pupils' answer sequences. You can assume that the number of different labels in each sequence doesn't exceed k.
 

Output

For each test case, output m lines, each line is a floating number (Round to 4 digits after the decimal point). You should output the m answers in the order of the sequences appearance.
 

Sample Input

     
     
2 10 3 3 A A B A B B C C C C F F E F E E D D D D X X X Y Y Y Y Z Z Z S T R S T R S T R S 3 2 2 A B A C D C F F E
 

Sample Output

1.0000

0.7000

0.5000

1.0000

0.6667


#include <iostream>
#include <cmath>
#include <string>
#include <string.h>
#include <cstdio>
#include <algorithm>

using namespace std;

#define MAXN 10000 + 10
#define MAXV 26
#define INF 200000

int temp[MAXN];
int c[MAXV][MAXV];
int lx[MAXV], ly[MAXV];
int slack[MAXV];
int match[MAXV];
bool visx[MAXV], visy[MAXV];
int best;

bool path(int u)
{
	visx[u] = true;
	
	for (int i = 0; i < MAXV; i++)
	{
		int t = lx[u] + ly[i] - c[u][i];
		
		if (!visy[i] && t == 0)
		{
			visy[i] = true;
			if (match[i] == -1 || path(match[i]))
			{
				match[i] = u;
				return true;
			}
		}
		else if (t < slack[i])
		{
			slack[i] = t;
		}
	}
	
	return false;
}

int solve()
{
	for (int i = 0; i < MAXV; i++)
	{
		lx[i] = c[i][0];
		ly[i] = 0;
		
		for (int j = 0; j < MAXV; j++)
		{
			if (c[i][j] > lx[i])
			{
				lx[i] = c[i][j];
			}		
		}
	}
	
	for (int u = 0; u < MAXV; u++)
	{
		if(lx[u] == 0) continue;
		
		for (int i = 0; i < MAXV; i++)
		{
			slack[i] = INF;
		}
		
		while (true)
		{	
			memset(visx, false, sizeof(visx));
			memset(visy, false, sizeof(visy));
			
			if (path(u))
			{
				break;
			}
			
			int inc = INF;
			
			for (int i = 0; i < MAXV; i++)
			{
				if (visx[i])
				{
					for (int j = 0; j < MAXV; j++)
					{
						if (!visy[j] && lx[i] + ly[j] - c[i][j] < inc)
						{
							inc = lx[i] + ly[j] - c[i][j];
						}
					}
				}	
			}
			
			for (int i = 0; i < MAXV; i++)
			{
				if (visx[i])
				{
					lx[i] -= inc;
				}
				if (visy[i])
				{
					ly[i] += inc;	
				}
				else
				{
					slack[i] -= inc;
				}
			}
		}
	}
	
	int sum = 0;
	
	for (int i = 0; i < MAXV; i++)
	{
		if (match[i] != -1)
			sum += c[match[i]][i];
	}
	
	return sum;
}

void input()
{
	int t;
	int n, k, m;
	char ch[3];
	
	cin >> t;
	
	while (t--)
	{
		scanf("%d %d %d", &n, &k, &m);
		
		for (int i = 0; i < n; i++)
		{
			scanf("%s", ch);
			temp[i] = ch[0] - 'A';
		}
		
		for (int i = 0; i < m; i++)
		{
			memset(c, 0, sizeof(c));
			memset(match, -1, sizeof(match));
			
			for (int j = 0; j < n; j++)
			{
				scanf("%s", ch);
				c[temp[j]][ch[0] - 'A']++;
			}
			
			best = 0;
			
			best = solve();
			
			printf("%.4lf\n", best * 1.0 / n);
		}
	}
}

int main()
{
	input();
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值