TOJ 2380 POJ 2536 Gopher II /二分图

Gopher II

时间限制(普通/Java):2000MS/20000MS     运行内存限制:65536KByte
 

描述

The gopher family, having averted the canine threat, must face a new predator.

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

输入

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

输出

Output consists of a single line for each case, giving the number of vulnerable gophers.

样例输入

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

样例输出

1

 

就是总的个数减去最大的匹配的个数就是答案 水题 上模板就行

#include <stdio.h>
#include <math.h>
#include <string>
#define MAX 110
struct point
{
	double x;
	double y;
};

point gopher[MAX],hole[MAX];
bool map[MAX][MAX],vis[MAX];
int Match[MAX];
int n,m;


bool dfs(int u)
{
	int i,j;
	for(i = 1; i <= m; i++)
	{
		if(map[u][i]&&!vis[i])
		{
			vis[i] = true;
			if(Match[i]==-1||dfs(Match[i]))
			{
				Match[i] = u;
				return true;
			}
		}
	}
	return false;
}
int match()
{
	memset(Match,-1,sizeof(Match));
	int i,ret = 0;
	for(i = 1; i <= n; i++)
	{
		memset(vis,false,sizeof(vis));
		if(dfs(i))
			ret++;
	}
	return n-ret;
}


double dis(point p1,point p2)
{
	return (p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y);
}
int main()
{
	int i,j;
	double s,v;
	while(scanf("%d %d %lf %lf",&n,&m,&s,&v)!=EOF)
	{
		memset(map,false,sizeof(map));
		
		for(i = 1; i <= n; i++)
			scanf("%lf %lf",&gopher[i].x,&gopher[i].y);
			
		for(i = 1; i <= m; i++)
			scanf("%lf %lf",&hole[i].x,&hole[i].y);
			
		for(i = 1;i <=n; i++)
		{
			for(j = 1; j <= m; j++)
			{
				if(dis(gopher[i],hole[j]) <= s*v*s*v)
				{
					map[i][j] = true;
				}
			}
		}
		printf("%d\n",match());
	}
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值