ZOJ Problem Set - 3782 Ternary Calculation

//网速太渣  打开百度空间  开了半天没半天 所以就申请了CSDB BLOG  有点没有道理啊。。第一篇送上


Complete the ternary calculation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a string in the form of "number1 operatora number2 operatorb number3". Each operator will be one of {'+', '-' , '*', '/', '%'}, and each number will be an integer in [1, 1000].

Output

For each test case, output the answer.

Sample Input
5
1 + 2 * 3
1 - 8 / 3
1 + 2 - 3
7 * 8 / 5
5 - 8 % 3
Sample Output
7
-1
0
11
3
Note

The calculation "A % B" means taking the remainder of A divided by B, and "A / B" means taking the quotient.


题意很好理解 就是简单的四则运算加上%运算  

一开始提交WA了好多次 原因是  测试数据中有空格  所以在读取/符号并进行运算时b=0  出现了分母为0的情况 报错 


代码如下:

<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <stack>
#include <cstring>

using namespace std;

stack<int> num;
stack<char> oper;
char ch[1010];


int main()
{
freopen("test.txt","r",stdin);
    int tc;
    cin>>tc;
    getchar();


    while(tc--)
    {
        gets(ch);
        int len=strlen(ch);
        for(int i=0;ch[i];i++)
        {
            if(ch[i]>='0'&&ch[i]<='9')
            {
                int temp=0;
                while(ch[i]>='0'&&ch[i]<='9')
                {
                    temp*=10;
                    temp+=ch[i]-'0';
                    i++;
                }
                i--;
                num.push(temp);
            }
            else if(ch[i]=='+'||ch[i]=='-')
                   {
                        if(!oper.empty())
                        {
                            char c=oper.top();
                            oper.pop();
                            int a=num.top();
                            num.pop();
                            int b=num.top();
                            num.pop();
                            if(c=='+')
                                a+=b;
                            else if(c=='-')
                                a=b-a;
                            num.push(a);
                            oper.push(ch[i]);
                        }
                        else
                            oper.push(ch[i]);
                   }
                   else if(ch[i]=='*'||ch[i]=='/'||ch[i]=='%')
                   {
                       char c=ch[i];
                       int b=0;
                       i+=2;//跳过空格
                       while(ch[i]>='0'&&ch[i]<='9')
                       {
                           b*=10;
                           b+=ch[i]-'0';
                           i++;
                       }
                       i--;
                       int a=num.top();
                       num.pop();
                       if(c=='/')
                           a=a/b;
                       else if(c=='*')
                           a=a*b;
                        else if(c=='%')
                           a=a%b;
                       num.push(a);
                   }
        }
        while(!oper.empty())
        {
            char c=oper.top();
            oper.pop();
            int a=num.top();
            num.pop();
            int b=num.top();
            num.pop();
            if(c=='+')
                a+=b;
            else
                a=b-a;
            num.push(a);
        }
        cout<<num.top()<<endl;
        //num.pop();
    }
    return 0;
}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值