zoj Burning Bridges(无向图割边)

Burning Bridges

Time Limit: 5 Seconds       Memory Limit: 32768 KB

Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?


Input

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.


Output

On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.

Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.


Sample Input

2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

Sample Output

2
3 7

1
4 

给定岛与岛之间的“桥” 现在要烧毁一些桥  但是要保证 从任意一个岛可以到达其他所有的岛  

问有哪些桥是不可以烧毁的


思路: 就是求出图中的割边  但是点与点之间有重边

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

void read(int &x)
{
    char ch;
    x=0;
    while(ch=getchar(),ch!=' '&&ch!='\n')
    {
        x=x*10+ch-'0';
    }
}

const int MAXN=10010;
const int MAXM=100010;

struct Edge
{
    int to,next,id;
}edge[2*MAXM];

int tol,tmpdfn,nbridge;
int head[MAXN],vis[MAXN],low[MAXN],dfn[MAXN];
int bridge[MAXM];//用来判断这个桥是不是割边

void init()
{
    tmpdfn=1;tol=0;nbridge=0;
    MEM(head,-1);
    MEM(bridge,0);
    MEM(vis,0);
}

void addedge(int u,int v,int id)
{
    //判重  速度慢
//    int i;
//    for(i=head[u];i!=-1;i=edge[i].next)
//    {
//        if(v==edge[i].to)
//            break;
//    }
//    if(i!=-1)
//    {
//        edge[i].tag=1;
//        edge[i^1].tag=1;
//        return;
//    }//判重时  要在struct里面加tag  加边时 初始化该边tag=0  edge[tol].tag=0
    edge[tol].to=v;  edge[tol].id=id;  edge[tol].next=head[u]; head[u]=tol++;
    edge[tol].to=u;  edge[tol].id=id;  edge[tol].next=head[v]; head[v]=tol++;
}

void dfs(int u,int id)
{
    low[u]=dfn[u]=++tmpdfn;
    vis[u]=1;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if(vis[v]==1&&edge[i].id!=id)
        {
            low[u]=min(low[u],dfn[v]);
        }
        else if(!vis[v])
        {
            dfs(v,edge[i].id);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
                bridge[edge[i].id]=++nbridge;
        }
    }
    vis[u]=2;
}

int main()
{
//    fread;
    int tc;
    scanf("%d",&tc);
    while(tc--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        init();
        for(int i=1;i<=m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v,i);
        }
        dfs(1,0);
        printf("%d\n",nbridge);
        for(int i=1,j=1;i<=m;i++)
        {
            if(bridge[i])
            {
                if(j==1)
                {
                    printf("%d",i);
                    j++;
                }
                else printf(" %d",i);
            }
        }
        if(nbridge) printf("\n");
        if(tc)  puts("");
    }

    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值