hdu 1059 Dividing(多重背包)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19539    Accepted Submission(s): 5491


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 


有价值为1,2,3,4,5,6的六种物品 各有ni件  现在要将这些物品分为两个部分

每个部分的价值和相同


#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 120010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int Read()
{
    char c = getchar();
    while (c < '0' || c > '9') c = getchar();
    int x = 0;
    while (c >= '0' && c <= '9') {
        x = x * 10 + c - '0';
        c = getchar();
    }
    return x;
}

void Print(int a)
{
     if(a>9)
         Print(a/10);
     putchar(a%10+'0');
}

int dp[MAXN];
int val[6]={1,2,3,4,5,6};
int n[6];
int m;

void ZeroOnePack(int wei,int val)
{
    for(int i=m;i>=wei;i--)
    {
        dp[i]=max(dp[i],dp[i-wei]+val);
    }
}

void CompletePack(int wei,int val)
{
    for(int i=wei;i<=m;i++)
    {
        dp[i]=max(dp[i],dp[i-wei]+val);
    }
}


void MultiPack(int wei,int val,int cnt)
{
    if(m<=wei*cnt)//总容量比物品所有的容量小 物品可以直到取完
    {
        CompletePack(wei,val);
        return ;
    }
    else
    {
        int k=1;
        while(k<=cnt)
        {
            ZeroOnePack(k*wei,k*val);
            cnt=cnt-k;
            k=2*k;
        }
        ZeroOnePack(cnt*wei,cnt*val);
    }
}

int main()
{
//    fread;
    int cs=1;
    while(scanf("%d",&n[0])!=EOF)
    {
        int sum=1*n[0];
        for(int i=1;i<6;i++)
        {
            scanf("%d",&n[i]);
            sum+=(i+1)*n[i];
        }
        int flag=0;
        for(int i=0;i<6;i++)
        {
            if(n[i])
            {
                flag=1;
                break;
            }
        }
        if(!flag) break;
        printf("Collection #%d:\n",cs++);
        if(sum%2)
        {
            puts("Can't be divided.");
            puts("");
            continue;
        }
//        cout<<"sum "<<sum<<endl;
        MEM(dp,0);
        m=sum;
        for(int i=0;i<6;i++)
        {
            MultiPack(i+1,i+1,n[i]);
        }
        sum/=2;
        if(dp[sum]==sum)
            puts("Can be divided.");
        else puts("Can't be divided.");
        puts("");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值