hihocoder Beautiful String

题目1 : Beautiful String

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

We say a string is beautiful if it has the equal amount of 3 or more continuous letters (in increasing order.)

Here are some example of valid beautiful strings: "abc", "cde", "aabbcc", "aaabbbccc".

Here are some example of invalid beautiful strings: "abd", "cba", "aabbc", "zab".

Given a string of alphabets containing only lowercase alphabets (a-z), output "YES" if the string contains a beautiful sub-string, otherwise output "NO".

输入

The first line contains an integer number between 1 and 10, indicating how many test cases are followed.

For each test case: First line is the number of letters in the string; Second line is the string. String length is less than 10MB.

输出

For each test case, output a single line "YES"/"NO" to tell if the string contains a beautiful sub-string.

提示

Huge input. Slow IO method such as Scanner in Java may get TLE.

样例输入
4
3
abc
4
aaab
6
abccde
3
abb
样例输出
YES
NO
YES
NO


判断一个字符串中有没有 符合要求的字符串 要求出现至少出现三个连续的字母 且每个字母的个数相等 

形如 aabbcc


直接统计每个字母连续出现的个数 因为只是要判断存不存在 所以直接判断有没有三个就好 因为最前最后的字母是可以丢弃的  所以要求两边的个数比中间大于等于

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 1000010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int Read()
{
    char c = getchar();
    while (c < '0' || c > '9') c = getchar();
    int x = 0;
    while (c >= '0' && c <= '9') {
        x = x * 10 + c - '0';
        c = getchar();
    }
    return x;
}

void Print(int a)
{
     if(a>9)
         Print(a/10);
     putchar(a%10+'0');
}

char ch[MAXN];
int a[MAXN],num[MAXN];

int main()
{
    //fread;
    int tc;
    scanf("%d",&tc);
    while(tc--)
    {
        int len;
        scanf("%d",&len); getchar();
        scanf("%s",ch);
        MEM(a,0); MEM(num,0);
        int y=0;
        a[y]=ch[0]-'a'+1;
        num[y]=1;
        for(int i=1;i<len;i++)
        {
            if((ch[i]-'a'+1)==a[y])
            {
                num[y]++;
            }
            else
            {
                y++;
                a[y]=ch[i]-'a'+1;
                num[y]=1;
            }
        }
        int flag=0;
        for(int i=0;i<=y-2;i++)
        {
            if(a[i]+1==a[i+1]&&a[i]+2==a[i+2]&&num[i]>=num[i+1]&&num[i+2]>=num[i+1])
            {
                flag=1;
                break;
            }
        }
        if(flag)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值