Beautiful String

时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
We say a string is beautiful if it has the equal amount of 3 or more continuous letters (in increasing order.)

Here are some example of valid beautiful strings: “abc”, “cde”, “aabbcc”, “aaabbbccc”.

Here are some example of invalid beautiful strings: “abd”, “cba”, “aabbc”, “zab”.

Given a string of alphabets containing only lowercase alphabets (a-z), output “YES” if the string contains a beautiful sub-string, otherwise output “NO”.

输入
The first line contains an integer number between 1 and 10, indicating how many test cases are followed.

For each test case: First line is the number of letters in the string; Second line is the string. String length is less than 10MB.

输出
For each test case, output a single line “YES”/”NO” to tell if the string contains a beautiful sub-string.

提示
Huge input. Slow IO method such as Scanner in Java may get TLE.

样例输入
4
3
abc
4
aaab
6
abccde
3
abb
样例输出
YES
NO
YES
NO

#include "iostream"
#include "set"
#include "algorithm"
#include "string"
#include "string.h"
#include "stdlib.h"
using namespace std;

int N;
char c[10485761];  //用(c,n)来表示一串连续相同的字母,比如"aaa"表示(a,3),"bb"表示为(b,2)
int n[10485761];

int ok(int len)
{
    int i;
    for(i=0; i<len-2; i++)
    {
        if(c[i]+1 == c[i+1] && c[i+1]+1 == c[i+2] && n[i] >= n[i+1] && n[i+1] <= n[i+2])
            return 1;
    }
    return 0;
}

int main()
{
    cin >> N;
    while(N--)
    {
        int len;
        cin >> len;
        string s;
        cin >> s;
        int i;
        int index = 0;
        memset(n, 0, sizeof(n));
        memset(c, 0, sizeof(c));
        for(i=0; i<len; i++)
        {
            int num = 0;
            while(s[i] == s[i+1])
            {
                i++;
                num++;
            }
            c[index] = s[i];
            n[index++] = num;
        }

        if(ok(len) == 1)
            cout <<  "YES" << endl;
        else
            cout << "NO" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值