hdu 2888 Check Corners(二维RMQ)

Check Corners

Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2307    Accepted Submission(s): 830


Problem Description
Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)
 

Input
There are multiple test cases. 

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer. 

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question. 
 

Output
For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.
 

Sample Input
  
  
4 4 4 4 10 7 2 13 9 11 5 7 8 20 13 20 8 2 4 1 1 4 4 1 1 3 3 1 3 3 4 1 1 1 1
 

Sample Output
  
  
20 no 13 no 20 yes 4 yes
 


裸的二维RMQ 求出小矩阵最大值之后判断是不是在角上就可以了

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int m,n;
int dmax[310][310][9][9];
int mm[310];
int val[310][310];

void RMQ_init()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            dmax[i][j][0][0]=val[i][j];
//    bug;
    for(int ii=0;ii<=mm[n];ii++)
        for(int jj=0;jj<=mm[m];jj++)
            if(ii+jj)
                for(int i=1;i+(1<<ii)-1<=n;i++)
                    for(int j=1;j+(1<<jj)-1<=m;j++)
    {
        if(ii)
        {
            dmax[i][j][ii][jj]=max(dmax[i][j][ii-1][jj],dmax[i+(1<<(ii-1))][j][ii-1][jj]);
        }
        else
        {
            dmax[i][j][ii][jj]=max(dmax[i][j][ii][jj-1],dmax[i][j+(1<<(jj-1))][ii][jj-1]);
        }
    }
//    bug;
}

int rmqmax(int x1,int y1,int x2,int y2)
{
    int k1=mm[x2-x1+1];
    int k2=mm[y2-y1+1];
    x2=x2-(1<<k1)+1;
    y2=y2-(1<<k2)+1;
    return max(max(dmax[x1][y1][k1][k2],dmax[x1][y2][k1][k2]),max(dmax[x2][y1][k1][k2],dmax[x2][y2][k1][k2]));
}


int main()
{
//    fread;
    mm[0]=-1;
    for(int i=1;i<=305;i++)
        mm[i]=((i&(i-1))==0)?mm[i-1]+1:mm[i-1];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&val[i][j]);
        RMQ_init();
        int q;
        scanf("%d",&q);
        while(q--)
        {
            int x1,y1,x2,y2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            if(x1>x2) swap(x1,x2);
            if(y1>y2) swap(y1,y2);
            int mx=rmqmax(x1,y1,x2,y2);
            printf("%d ",mx);
            if(mx==val[x1][y1]||mx==val[x2][y1]||mx==val[x1][y2]||mx==val[x2][y2])
                puts("yes");
            else puts("no");
        }
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值