poj 2479 Maximum sum (子序列和最大问题)

 Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31388 Accepted: 9627

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended

题目是求两个连续区间的最大序列和问题,可以用两个数组分别记录从左右区间过来的到当前位置的最大区间和;
然后,枚举中间点,取左右区间和最大的。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
#define mem(a,t) memset(a,t,sizeof(a))
#define N 105
const int inf=0x1f1f1f1f;
int main()
{
    int T,n,i,mmax;
	int a[N];
	int l[N],r[N];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		mem(l,0);
		mem(r,0);
		l[0]=a[0];
		for(i=1;i<n;i++)
			l[i]=max(a[i],l[i-1]+a[i]);
		mmax=-inf;
		for(i=0;i<n;i++)
		{
			mmax=max(mmax,l[i]);
			l[i]=mmax;
		}
		r[n-1]=a[n-1];
		for(i=n-2;i>=0;i--)
			r[i]=max(a[i],r[i+1]+a[i]);
		mmax=-inf;
		for(i=n-1;i>=0;i--)
		{
			mmax=max(mmax,r[i]);
			r[i]=mmax;
		}
		mmax=-inf;
		for(i=0;i<n-1;i++)
			mmax=max(mmax,l[i]+r[i+1]);
		printf("%d\n",mmax);
	}
    return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值