poj 3026 Borg Maze

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7722 Accepted: 2592

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

最小生成树+bfs(求个点之间距离)

注意数组稍微开大一点,还有空格问题。。

#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 200         //N为100就wrong了
#define M 200
const int inf=10000;
int map[N][N];         //记录个点之间距离
char str[N][N];
int row,col;          //行和列
int dx[4]={0,0,-1,1};
int dy[4]={1,-1,0,0};
struct node
{
	int x,y,t;
	friend bool operator<(node a,node b)
	{                            //距离短的优先级高
		return a.t>b.t;
	}
}f[M];
int judge(int x,int y)        
{
	if(x>=0&&x<row&&y>=0&&y<col&&str[x][y]!='#')
		return 1;
	return 0;
}
void bfs(int index,int n)
{
	int i,di,dj;
	int mark[M][M];        //标记该点是否在队列
	priority_queue<node>q;
	node cur,next;
	cur.x=f[index].x;
	cur.y=f[index].y;
	cur.t=0;
	q.push(cur);
	memset(mark,0,sizeof(mark));
	mark[cur.x][cur.y]=1;
	while(!q.empty())
	{
		cur=q.top();
		q.pop();
		for(i=0;i<n;i++)            //每次取队首元素看是否是另一点,
		{                             //刚开始的方法超时
			if(cur.x==f[i].x&&cur.y==f[i].y)
			{
				map[index][i]=map[i][index]=cur.t;
				break;
			}
		}
		for(i=0;i<4;i++)
		{
			next.x=di=cur.x+dx[i];
			next.y=dj=cur.y+dy[i];
			next.t=cur.t+1;
			if(judge(di,dj)&&!mark[di][dj])
			{
				mark[di][dj]=1;
				q.push(next);
			}
		}
	}
}
int prim(int n)
{
	int i,index,min,sum=0;
	int dis[M],mark[M];
	for(i=0;i<n;i++)
		dis[i]=map[0][i];
	memset(mark,0,sizeof(mark));
	mark[0]=1;
	while(1)
	{
		index=-1;
		min=inf;
		for(i=0;i<n;i++)
			if(!mark[i]&&dis[i]<min)
			{
				min=dis[i];
				index=i;
			}
		if(index==-1)
			return sum;
		mark[index]=1;
		sum+=min;
		for(i=0;i<n;i++)
			if(!mark[i]&&dis[i]>map[index][i])
				dis[i]=map[index][i];
	}
	return 0;
}
int main()
{
	int T,i,j,n;
	char temp[200];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&col,&row);
		gets(temp);               //空格会有多个
		for(i=0;i<row;i++)
			gets(str[i]);
		for(i=0,n=0;i<row;i++)
			for(j=0;j<col;j++)
			{
				if(str[i][j]=='S'||str[i][j]=='A')
				{
					f[n].x=i;
					f[n++].y=j;
				}
			}
		for(i=0;i<n;i++)
			bfs(i,n);           //把该点与所有点的距离都求出来
		printf("%d\n",prim(n));
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值