Can you find it?
Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)Total Submission(s): 9863 Accepted Submission(s): 2587
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
Sample Output
Case 1: NO YES NO
主要是把两个数组合并为一个数,这一点没想起来。
然后二分查找,因为只需要判断能否找到该元素,所以一般的二分查找就行。
#include"stdio.h"
#include"string.h"
#include"stdlib.h"
#define N 505
int a[N],b[N],c[N];
int ab[N*N];
int cmp(const void*a,const void*b)
{
return *(int*)a-*(int*)b;
}
int find(int x,int high) //二分查找
{
int mid,low=0;
while(low<=high)
{
mid=(low+high)/2;
if(ab[mid]>x)
high=mid-1;
else if(ab[mid]<x)
low=mid+1;
else
return 1;
}
return 0;
}
int main()
{
int l,m,n;
int s,q,i,j,k,cnt=1;
while(scanf("%d%d%d",&l,&m,&n)!=-1)
{
for(i=0;i<l;i++)
scanf("%d",&a[i]);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
for(i=0;i<n;i++)
scanf("%d",&c[i]);
for(i=0,k=0;i<l;i++) //把两个数组和为一个数组
{
for(j=0;j<m;j++)
ab[k++]=a[i]+b[j];
}
qsort(ab,k,sizeof(ab[0]),cmp);
qsort(c,n,sizeof(c[0]),cmp);
scanf("%d",&q);
printf("Case %d:\n",cnt++);
while(q--)
{
scanf("%d",&s);
int flag=0;
for(i=0;i<n;i++)
{
if(find(s-c[i],k))
{
flag=1;
break;
}
}
if(flag)
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}