hdu 4619 Warm up 2 (二分图)

Warm up 2

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1754    Accepted Submission(s): 781


Problem Description
  Some 1×2 dominoes are placed on a plane. Each dominoe is placed either horizontally or vertically. It's guaranteed the dominoes in the same direction are not overlapped, but horizontal and vertical dominoes may overlap with each other. You task is to remove some dominoes, so that the remaining dominoes do not overlap with each other. Now, tell me the maximum number of dominoes left on the board.
 

Input
  There are multiple input cases.
  The first line of each case are 2 integers: n(1 <= n <= 1000), m(1 <= m <= 1000), indicating the number of horizontal and vertical dominoes.
Then n lines follow, each line contains 2 integers x (0 <= x <= 100) and y (0 <= y <= 100), indicating the position of a horizontal dominoe. The dominoe occupies the grids of (x, y) and (x + 1, y).
  Then m lines follow, each line contains 2 integers x (0 <= x <= 100) and y (0 <= y <= 100), indicating the position of a horizontal dominoe. The dominoe occupies the grids of (x, y) and (x, y + 1).
  Input ends with n = 0 and m = 0.
 

Output
  For each test case, output the maximum number of remaining dominoes in a line.
 

Sample Input
  
  
2 3 0 0 0 3 0 1 1 1 1 3 4 5 0 1 0 2 3 1 2 2 0 0 1 0 2 0 4 1 3 2 0 0
 

Sample Output
  
  
4 6
 

Source

题意:一个多米诺骨牌占两个格子,有的占水平的两个格子,有的占据垂直的两个格子,这些多米诺骨牌有的重叠。现在需要移去相互重叠的,求最多留下几个多米诺骨牌。

思路:一个多米诺骨牌占两个格子连一条边,求最大匹配OK!

#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 105
#define M 4005
int mark[M],link[M],g[N][N];
int n,m,t;
int head[M];
int dir[4][2]={0,1,0,-1,-1,0,1,0};
struct node
{
    int u,v,next;
}map[M];
int max(int a,int b)
{
    return a>b?a:b;
}
void add(int u,int v)
{
    map[t].u=u;
    map[t].v=v;
    map[t].next=head[u];
    head[u]=t++;
}
int find(int k)
{
    int i,v;
    for(i=head[k];i!=-1;i=map[i].next)
    {
        v=map[i].v;
        if(!mark[v])
        {
            mark[v]=1;
            if(link[v]==-1||find(link[v]))
            {
                link[v]=k;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,u,v,cnt;
    while(scanf("%d%d",&n,&m),n||m)
    {
        memset(g,-1,sizeof(g));
        memset(map,0,sizeof(map));
        memset(head,-1,sizeof(head));
        t=0;
        cnt=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            if(g[u][v]==-1)
            {
                g[u][v]=cnt++;
            }
            if(g[u+1][v]==-1)
            {
                g[u+1][v]=cnt++;
            }
            add(g[u][v],g[u+1][v]);
            add(g[u+1][v],g[u][v]);
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            if(g[u][v]==-1)
            {
                g[u][v]=cnt++;
            }
            if(g[u][v+1]==-1)
            {
                g[u][v+1]=cnt++;
            }
            add(g[u][v],g[u][v+1]);
            add(g[u][v+1],g[u][v]);
        }
        int ans=0;
        memset(link,-1,sizeof(link));
        for(i=0;i<cnt;i++)
        {
            memset(mark,0,sizeof(mark));
            ans+=find(i);
        }
        printf("%d\n",ans/2);
    }
    return 0;
}

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值