zoj 1232 Adventure of Super Mario (Floyd+dp)

Adventure of Super Mario

Time Limit: 2 Seconds       Memory Limit: 65536 KB

After rescuing the beautiful princess, Super Mario needs to find a way home -- with the princess of course :-) He's very familiar with the 'Super Mario World', so he doesn't need a map, he only needs the best route in order to save time.

There are A Villages and B Castles in the world. Villages are numbered 1..A, and Castles are numbered A+1..A+B. Mario lives in Village 1, and the castle he starts from is numbered A+B. Also, there are two-way roads connecting them. Two places are connected by at most one road and a place never has a road connecting to itself. Mario has already measured the length of every road, but they don't want to walk all the time, since he walks one unit time for one unit distance(how slow!).

Luckily, in the Castle where he saved the princess, Mario found a magic boot. If he wears it, he can super-run from one place to another IN NO TIME. (Don't worry about the princess, Mario has found a way to take her with him when super-running, but he wouldn't tell you :-P)

Since there are traps in the Castles, Mario NEVER super-runs through a Castle. He always stops when there is a castle on the way. Also, he starts/stops super-runnings ONLY at Villages or Castles.

Unfortunately, the magic boot is too old, so he cannot use it to cover more than L kilometers at a time, and he cannot use more than K times in total. When he comes back home, he can have it repaired and make it usable again.


Input

The first line in the input contains a single integer T, indicating the number of test cases. (1<=T<=20) Each test case begins with five integers A, B, M, L and K -- the number of Villages, the number of Castles(1<=A,B<=50), the number of roads, the maximal distance that can be covered at a time(1<=L<=500), and the number of times the boot can be used. (0<=K<=10) The next M lines each contains three integers Xi, Yi, Li. That means there is a road connecting place Xi and Yi. The distance is Li, so the walk time is also Li. (1<=Li<=100)


Output

For each test case in the input print a line containing a single integer indicating the minimal time needed to go home with the beautiful princess. It's guaranteed that Super Mario can always go home.


Sample Input

1
4 2 6 9 1
4 6 1
5 6 10
4 5 5
3 5 4
2 3 4
1 2 3


Sample Output

9

题意:给定N个点求1-N的最短路,所加的附加条件就是这N个点前A个点为村庄,后B个点为城堡。马里奥用一双靴子,能够在一定距离(L)内花0时间进行穿梭,且只有K次机会,但使用鞋子时不能穿过城堡。在这种情况下,求解一个最短路。

思路:先用Floyd求得任意两点间距离,然后,枚举每个点,具体看代码吧。。。


#include"stdio.h"
#include"string.h"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 105
const int inf=1000000;
int can[N][N],e[N][N],dp[N][11];
int min(int a,int b)
{
    return a<b?a:b;
}
int main()
{
    int T,a,b,l,m,n,K;
    int i,j,k,u,v,d;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d",&a,&b,&m,&l,&K);
        n=a+b;
        for(i=1;i<=n;i++)  //数组初始化,
        {
            for(j=1;j<=n;j++)
            {
                e[i][j]=(i==j?0:inf);
                can[i][j]=0;   
            }
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&d);
            e[u][v]=e[v][u]=d;
            if(d<=l)       
                can[u][v]=can[v][u]=1;
        }
        for(k=1;k<=n;k++)      //floyd算法求任意两点间最短路
        {
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    if(e[i][j]>e[i][k]+e[k][j])
                    {
                        e[i][j]=e[i][k]+e[k][j];
                        if(e[i][j]<=l&&k<=a)
                            can[i][j]=1;
                    }
                }
            }
        }
        for(i=1;i<=n;i++)
            dp[i][0]=e[1][i];
        for(i=2;i<=n;i++)
        {
            for(j=1;j<=K;j++)
            {             //dp[i][j]代表通过前i-1个点走到第 i 点,用了j次鞋子的最少时间;
                int tmp=inf;  //枚举在前i个点在[k,i]这一段使用第j次鞋子,用的最少时间
                for(k=1;k<i;k++)     //tmp记录该值
                {
                    if(can[k][i])
                    {
                        tmp=min(tmp,min(dp[k][j-1],dp[k][j]+e[k][i]));
                    }      //在[k,i]这段使用第j次鞋子,不使用鞋子的最小值
                    else
                        tmp=min(tmp,dp[k][j]+e[k][i]);
                }
                dp[i][j]=tmp;
            }
        }
        printf("%d\n",dp[n][K]);
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值