Differences

CXB attended an interview and the interviewer given him a problem. The problem asked him to be in a sequence to find the difference between the maximum and minimum values.

Input

The first line of the input contains ca (ca ≤ 1000).

The following ca test case. For each test case, there are two lines. There is a integer number of n in the first line (1 ≤ ≤ 1000). There are n number of integer numbers in next line. The range of each number is [-264+1,264-1].

Output

For each case, print the answer.

Sample Input

1
5
1 2 3 4 5

Sample Output

4




题意概述:纯属水题,不多说了。

解题思路:在输入的同时更新最大值和最小值,输出最大值与最小值之差,唯一需要注意的是要使用long long int。

源代码:


#include<iostream>
using namespace std;
int main()
{
    int T,N;
    long long int min,max,num;
    cin>>T;
    while(T--)
    {
         cin>>N;
         cin>>num;
         min=max=num;
         for(int i=1;i<N;++i)
         {
             cin>>num;
             if(min>num)min=num;
             if(max<num)max=num;
         }
         cout<<max-min<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值