TOJ 3498.Differences

题目链接:http://acm.tju.edu.cn/toj/showp3498.html


3498.    Differences
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 860    Accepted Runs: 310



CXB attended an interview and the interviewer given him a problem. The problem asked him to be in a sequence to find the difference between the maximum and minimum values.

Input

The first line of the input contains ca (ca ≤ 1000).

The following ca test case. For each test case, there are two lines. There is a integer number of n in the first line (1 ≤ ≤ 1000). There are n number of integer numbers in next line. The range of each number is [-264+1,264-1].

Output

For each case, print the answer.

Sample Input

1
5
1 2 3 4 5

Sample Output

4



Source: TJRAC Team Selection 2010 (2)
Submit   List    Runs   Forum   Statistics

水题,上代码:


#include <stdio.h>
#define MAX (long long)1<<62
int main(){
	int ca,n;
	long long number,maxnum,minnum;
	scanf("%d",&ca);
	while(ca--){
		scanf("%d",&n);
		maxnum=-1*MAX;
		minnum=MAX;
		for(int i=0;i<n;i++){
			scanf("%lld",&number);
			if(maxnum<number)
				maxnum=number;
			if(minnum>number)
				minnum=number;
		}
		printf("%lld\n",maxnum-minnum);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值