摆布大三角

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input
Your program is to read from standard input.
For each test case, the first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Process to the end of file.


Output
For each test case, your program is to write to standard output. The highest sum is written as an integer.

Sample Input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5


Sample Output

30


#include<iostream> 
using namespace std; 
  
int max(int a,int b) 
{ 
    return a>b?a:b; 
} 
  
int main(int i,int j) 
{ 
    int n; 
    while(cin>>n) 
    { 
        int **way=new int*[n+1];   //动态申请二维数组的第一维,每个元素都是一个一维数组的指针 
  
        /*Input & Initial*/
  
        for(i=0;i<=n;i++) 
        { 
            way[i]=new int[i+2]; //动态申请二维数组的第二维,每一行的空间 
            for(j=0;j<=i+1;j++) 
                way[i][j]=0;   //不能用memset初始化 
  
            if(i!=0) 
                for(j=1;j<=i;j++) 
                    cin>>way[i][j]; 
        } 
  
        /*Dp*/
  
        int max_weight=0; 
        for(i=1;i<=n;i++) 
            for(j=1;j<=i;j++) 
            { 
                way[i][j] += max(way[i-1][j-1],way[i-1][j]); 
  
                if(i==n && max_weight<way[i][j]) 
                    max_weight=way[i][j]; 
            } 
  
        cout<<max_weight<<endl; 
  
        delete[] way; 
    } 
    return 0; 
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值