【PAT】【Advanced Level】1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
原题链接:

https://www.patest.cn/contests/pat-a-practise/1009

https://www.nowcoder.com/questionTerminal/9c06e801f8f54ebcb170c09117265132

思路:

由于精度问题,此题卡掉了map的做法,在牛客网上可过,在pat上不能通过所有测试点

就用朴素的的二维数组即可

仍然要注意系数为0的情况

code:

#include<iostream>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<cstdio>
#include<cmath>
using namespace std;
typedef struct S
{
  int z;
  double x;
};
bool fl[2010];
int  re[42];

double jg[2010];

int main()
{
    memset(fl,0,sizeof(fl));
    memset(jg,0,sizeof(jg));
    int n1,n2;
    cin>>n1;
    S a[n1];
    for (int i=0;i<n1;i++)
        cin>>a[i].z>>a[i].x;
    cin>>n2;
    S b[n2];
    for (int i=0;i<n2;i++)
    {
        cin>>b[i].z>>b[i].x;
        for (int j=0;j<n1;j++)
        {
            int s1=0;
            double s2=0;
            s1=b[i].z+a[j].z;
            s2=b[i].x*a[j].x;
            //cout<<s2<<endl;
            jg[s1]+=s2;
        }
    }
    int num=0;
    for(int i=0;i<2010;i++)
        if (jg[i]!=0) num++;
    cout<<num;
    for (int i=2010;i>=0;i--)
        if (jg[i]!=0)
            printf(" %d %.1lf",i,jg[i]);
    printf("\n");
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值