1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
用到(小数点保留一位)
cout<<setiosflags(ios::fixed)<<setprecision(1)<<index[i];
需要头文件#include<iomanip>

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月17日 20:46答案正确251009C++ (g++ 4.7.2)1360datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确12565/5
1答案正确13605/5
2答案正确13605/5
3答案正确12325/5
4答案正确12325/5
 
#include<iostream>
#include<iomanip>
#include<math.h>
using namespace std;
#define esp 0.05
int main()
{
 double index[2001]={0},e[2][11];
 int index1[2][11];
 int n1,n2,i,j,count;  
 cin>>n1; 
 for(i=0;i<n1;i++)
 {
  cin>>index1[0][i]>>e[0][i];
 } 
 cin>>n2; 
 for(i=0;i<n2;i++)
 {  
  cin>>index1[1][i]>>e[1][i];
  {
   for(j=0;j<n1;j++)
   {
    index[index1[0][j]+index1[1][i]]+=e[0][j]*e[1][i];
   }
  }
 }  
 i=2001;
 count=0;
 while(i--)
 {
  if(fabs(index[i])>esp)count++;
 }
 cout<<count;
 i=2001;
 while(i--)
 {
  if(fabs(index[i])>esp){
            cout<<" "<<i<<" ";
   cout<<setiosflags(ios::fixed)<<setprecision(1)<<index[i];}
 }
 cout<<endl;
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值