【PAT】【Advanced Level】1086. Tree Traversals Again (25)

14 篇文章 0 订阅

1086. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
题目链接:

https://www.patest.cn/contests/pat-a-practise/1086

思路:

根据前序、中序求后序

不用建树,利用栈,针对每一个节点,先将此节点压入栈,然后先遍历右子树,再遍历左子树。

最后将栈里的元素一一弹出输出即可。

CODE:

#include<iostream>
#include<vector>
#include<stack>
using namespace std;

vector<int> pre;
vector<int> mid;
stack<int> st;
stack<int> ot;


void dfs(int l1,int r1,int l2 ,int r2)
{
	ot.push(pre[l1]);
	int mi=pre[l1];
	int pos;
	for (int i=l2;i<=r2;i++)
	{
		if (mid[i]==mi) 
		{
			pos=i;
			break;
		}
	}
	if (pos!=r2)
	{
		dfs(l1+(pos-l2)+1,r1,pos+1,r2);
	}
	if (pos!=l2)
	{
		dfs(l1+1,l1+(pos-l2),l2,pos-1);
	}		
}
int main()
{
	int n;
	cin>>n;
	int now=0;
	string t;
	while(cin>>t)
	{	
		//if (t=="-1") break;
		if (t=="Push")
		{
			int va;
			cin>>va;
			st.push(va);
			pre.push_back(va);
		}
		else
		{
			mid.push_back(st.top());
			st.pop();
		}
	}
	/*
	for (int i=0;i<n;i++)
	{
		cout<<pre[i]<<" ";
	}
	cout<<endl;
	for (int i=0;i<n;i++)
	{
		cout<<mid[i]<<" ";
	}
	cout<<endl;
	*/
	dfs(0,n-1,0,n-1);
	while (!ot.empty())
	{
		cout<<ot.top();
		ot.pop();
		if (!ot.empty())cout<<" ";
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值