PAT (Advanced Level) Practice 1020 Tree Traversals (25 分)

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

Code:

#include <iostream>
#include <queue>
#pragma warning(disable:4996)

using namespace std;

const int MAXN = 31;

struct Node
{
	int v;
	Node *l, *r;
	Node() : v(-1), l(nullptr), r(nullptr) {};
};

Node* buildTree(int len, int post_order[], int in_order[])
{
	if (len < 1)
		return nullptr;
	Node* root = new Node;
	root->v = post_order[len - 1];
	int i;
	for (i = 0; i < len; i++)
		if (in_order[i] == post_order[len - 1]) break;
	root->l = buildTree(i, post_order, in_order);
	root->r = buildTree(len - i - 1, post_order + i, in_order + i + 1);
	return root;
}

void level_traversals(Node* nd)
{
	queue<Node*> qNode;
	qNode.push(nd);
	bool but = true;
	while (!qNode.empty())
	{
		Node* temp = qNode.front();
		qNode.pop();
		if (temp->l != nullptr) qNode.push(temp->l);
		if (temp->r != nullptr) qNode.push(temp->r);
		if (but)
		{
			printf("%d", temp->v);
			but = false;
		}
		else
			printf(" %d", temp->v);
	}
	printf("\n");
}

int main()
{
	int N;
	scanf("%d", &N);
	int post_order[MAXN];
	int in_order[MAXN];
	for (int i = 0; i < N; i++)
		scanf("%d", &post_order[i]);
	for (int i = 0; i < N; i++)
		scanf("%d", &in_order[i]);
	Node* head = buildTree(N, post_order, in_order);
	level_traversals(head);
	return 0;
}

思路

算法流程是这样的,找到后续遍历数列的最后一个数,它是根节点,然后在中序遍历数列中找到这个节点,中序遍历数列中在这个节点左边的是这个节点的左子树,这个节点右边的是这个节点的右子树,更新数组长度,后序遍历数组,中序遍历数组。

以上

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值