【PAT】【Advanced Level】1119. Pre- and Post-order Traversals (30)

14 篇文章 0 订阅
8 篇文章 0 订阅

1119. Pre- and Post-order Traversals (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Special
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line "Yes" if the tree is unique, or "No" if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
1 2 3 4 6 7 5
2 6 7 4 5 3 1
Sample Output 1:
Yes
2 1 6 4 7 3 5
Sample Input 2:
4
1 2 3 4
2 4 3 1
Sample Output 2:
No
2 1 3 4
原题链接:

https://www.patest.cn/contests/pat-a-practise/1119

思路:

利用前序、后序找中序

对于每一棵树以及子树

前序的第一个、后序的最后一个是根节点

前序的第二个是左子树根节点,后序倒数第二个是右子树根节点

若相同,则说明只有一棵子树,出现歧义。

若没有歧义,则从前序序列中找到后序的根节点,确定左右子树的在序列中的范围,然后继续递归查找。

对于中序序列的输出,每次先递归左子树,再压入根节点,再递归右子树即可

坑点:

格式问题:最后一行输出后要换行,否则格式错误。。

CODE:

#include<iostream>
#include<vector>
#define N 36
using namespace std;
int pre[N];
int post[N];
bool flag;
vector<int> res;
void fi(int l1,int r1,int l2,int r2)
{
	if (l1==r1)
	{
		res.push_back(pre[l1]);
		return ;
	}
	int pos=0;
	for (int i=l1+1;i<=r1;i++)
	{
		if (pre[i]==post[r2-1])
		{
			pos=i;
			break;
		}
	}
	int lenl=pos-l1-1;
	int lenr=r1-pos+1;
	if (pos==l1+1)	flag=1;
	else fi(l1+1,l1+lenl,l2,l2+lenl-1);
	res.push_back(pre[l1]);
	fi(pos,r1,r2-lenr,r2-1);
}
int main()
{
	int n;
	cin>>n;
	for (int i=0;i<n;i++)	cin>>pre[i];
	for (int i=0;i<n;i++)	cin>>post[i];
	flag=0;
	fi(0,n-1,0,n-1);
	if (flag==0) 
		cout<<"Yes"<<endl;
	else
		cout<<"No"<<endl;
	for (int i=0;i<res.size();i++)
	{
		if (i!=0) cout<<" ";
		cout<<res[i];
	}
	cout<<endl;
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值