【PAT】【Advanced Level】1122. Hamiltonian Cycle (25)

9 篇文章 0 订阅

1122. Hamiltonian Cycle (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO

原题链接:

https://www.patest.cn/contests/pat-a-practise/1122

思路:

邻接矩阵存储图。

判断哈密顿环:

节点数不对,排除

首尾不一致,排除

走过重复节点,排除

两点之间没有通路,排除

CODE:

#include<iostream>
#include<map>
#include<vector>
#include<cstring>
#define N 210
using namespace std;
int dist[N][N];
int main()
{
	memset(dist,-1,sizeof(dist));
	int n,m;
	cin>>n>>m;
	for (int i=0;i<m;i++)
	{
		int s,e;
		cin>>s>>e;
		dist[s][e]=dist[e][s]=1;
	}
	int k;
	cin>>k;
	for (int i=0;i<k;i++)
	{
		int t;
		cin>>t;
		vector<int> pa;
		for (int j=0;j<t;j++)
		{
			int temp;
			cin>>temp;
			pa.push_back(temp);
		}
		if (t!=n+1 || pa[0]!=pa[t-1])
		{
			cout<<"NO"<<endl;
			continue;
		}
		bool fl[n+1];
		memset(fl,0,sizeof(fl));
		fl[pa[0]]=1;
		bool flag=0;
		for (int j=1;j<t;j++)
		{
			//cout<<pa[j-1]<<" "<<pa[j]<<" "<<dist[pa[j-1]][pa[j]]<<endl;
			if (dist[pa[j-1]][pa[j]]==-1 || (j!=t-1&&fl[pa[j]]==1))
			{
				flag=1;
				break;
			}
			fl[pa[j]]=1;
		}
		if (flag==0)	cout<<"YES"<<endl;
		else	cout<<"NO"<<endl;
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值