PAT (Advanced Level) 1122. Hamiltonian Cycle (25)

1122. Hamiltonian Cycle (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO

说实话,这道题虽然题目意思好懂,但是!!有点坑~

首先是在遍历图的时候每遍历完一次都要记得对flag和vis重新初始化一遍~

然后就是我一直第二个测试点过不去,后来又去请教了大神,大神一秒钟指出了我的错误~我在对vector<int> v遍历的时候,只是到t-2就停下来了,然后检查sum是否等于n-1,因为我很想当然的觉得头尾两个数字一样,没必要去检验倒数第二个数字与最后一个数字之间是否联通,第二个测试点应该就是卡这个。。。一定要检查他们是否联通~(好吧。。有时候思考问题的时候就会脑残了,因为只是一味的想着第一个数字的vis已经被置成了true,所以最后一个数字不需要遍历,但是没有考虑到联通的问题啊。。。)

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
#include<vector>

using namespace std;

const int maxn = 210;

int n, m, G[maxn][maxn];
int t, flag;
bool vis[maxn] = { false };
vector<int> v;

void bianli() {
	fill(vis, vis + maxn, 0);
	flag = 0;
	int st, ed, sum = 0;
	st = v[0];
	ed = v[t - 1];
	if (st != ed) {
		return;
	}

	for (int i = 0; i < t - 1; i++) {
		if (vis[v[i]] == false && G[v[i]][v[i + 1]] == 1) {
			vis[v[i]] = true;
			sum++;
		}
		else {
			return;
		}
	}
	if (sum == n) {
		flag = 1;
		return;
	}
	else {
		return;
	}
}

int main() {
	scanf("%d%d", &n, &m);
	for (int i = 0; i < m; i++) {
		int a, b;
		scanf("%d%d", &a, &b);
		G[a][b] = G[b][a] = 1;
	}

	int s;
	scanf("%d", &s);
	for (int i = 0; i < s; i++) {
		v.clear();
		scanf("%d", &t);
		for (int j = 0; j < t; j++) {
			int temp;
			scanf("%d", &temp);
			v.push_back(temp);
		}
		bianli();
		if (flag) {
			printf("YES\n");
		}
		else {
			printf("NO\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值