PAT(Advanced Level)1122. Hamiltonian Cycle

1122. Hamiltonian Cycle (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
        第一次考pat,结果第三题就卡在这个地方了,哎,最后一个三分怎么也过不了,求哈密顿回路,判断起点终点是否一致,在判断节点数是否是N+1,然后再从起点开始,一个点一个点的走,走一个标记一个,看能否回到起点。最后回来发现我的标记数组重定义了,一个是全局变量,一个是局部变量,改了改就过了,一战没考好,二战终于满分了,终于得到了回报啊

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <set>
using namespace std;
int n,m,k,q;
int a[205][205],b[205];
int main()
{
    cin>>n>>m;
    int u,v;
    for(int i = 0;i < m;i++){
        cin>>u>>v;
        a[u][v] = 1;
        a[v][u] = 1;
    }
    cin>>q;
    while(q--){
        cin>>k;
        set<int>s;
        for(int i = 0;i < k;i++){
            cin>>b[i];
            s.insert(b[i]);
        }
        if(k!=(n+1)||b[0]!=b[k-1]||s.size()!=n){
            printf("NO\n");
            continue;
        }
        int f = 0;
        for(int i = 1;i < k;i++){
            if(!a[b[i-1]][b[i]]){
                f = 1;
                printf("NO\n");
                break;
            }
        }
        if(!f)printf("YES\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值