ubuntu16.04安装virtualbox

最近研究Ubuntu系统,安装的是Ubuntu16.04,打算装一个virtualbox,浪费了我一天的时间。

不知道出于什么原因Ubuntu16.04安装virtualbox-4.3装不上

一直在报内核出错的问题,我尝试了各种方法还是无果,猜测是版本的问题,这里推荐各位安装virtualbox-5.0以上的版本比较好

1.到oracle的https://www.virtualbox.org/网站下载ubuntu平台最新版的virtualbox软件,我下载的是virtualbox-5.1_5.1.18-114002~Ubuntu~xenial_amd64.deb
2执行如下命令进行安装

sudo dpkg -i virtualbox-5.1_5.1.18-114002~Ubuntu~xenial_amd64.deb

安装中会报错 需要依赖的 libqt5x11extras5和 libsdl1.2debian
执行如下命令进行安装

apt-get install  libqt5x11extras5 libsdl1.2debian

再次执行

sudo dpkg -i virtualbox-5.1_5.1.18-114002~Ubuntu~xenial_amd64.deb

成功!

阅读更多
换一批

没有更多推荐了,返回首页