HDU 2196-Computer-树形dp-模板

Description

A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
在这里插入图片描述

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input

5
1 1
2 1
3 1
1 1

Sample Output

3
2
3
4
4

核心思想:

树形dp模板题。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=1e4+20;
struct node{
	int y,v,ne;
}side[N];
//dp[i][0]表示向下最长距离,dp[i][1]表示向下次长距离,dp[i][2]表示向上最长距离 
int head[N],cnt,dis[N][3],l[N];
void add(int x,int y,int v)
{
	side[cnt].y=y;
	side[cnt].v=v;
	side[cnt].ne=head[x];
	head[x]=cnt++;
	return;
}
//利用回溯更新向下的最长和次长距离 
int dfs1(int x)
{ 
	if(dis[x][0]!=-1)
		return dis[x][0];
	dis[x][0]=dis[x][1]=0;
	for(int i=head[x];i!=-1;i=side[i].ne)
	{
		int ty=side[i].y;
		int tv=side[i].v;
		//更新最长距离和次长距离 
		if(dis[x][0]<dfs1(ty)+tv)
		{
			l[x]=ty;
			dis[x][1]=dis[x][0];
			dis[x][0]=dfs1(ty)+tv;
		}
		//更新次长距离 
		else if(dis[x][1]<dfs1(ty)+tv)
			dis[x][1]=dfs1(ty)+tv;
	}
	return dis[x][0];
}
//自上而下的更新向上最长距离 
void dfs2(int x)
{
	for(int i=head[x];i!=-1;i=side[i].ne)
	{
		int ty=side[i].y;
		int tv=side[i].v;
		//先更新后递归 
		if(ty==l[x])
			dis[ty][2]=max(dis[x][2],dis[x][1])+tv;
		else
			dis[ty][2]=max(dis[x][2],dis[x][0])+tv;
		dfs2(ty);
	}
	return;
}
int main()
{
	int n,x,v;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<N;i++)
		{
			head[i]=-1;
			for(int j=0;j<3;j++)
				dis[i][j]=-1;
		}
		cnt=0;
		dis[1][2]=0;
		for(int i=2;i<=n;i++)
		{
			scanf("%d%d",&x,&v);
			add(x,i,v);
		}
		dfs1(1);
		dfs2(1);
		for(int i=1;i<=n;i++)
			printf("%d\n",max(dis[i][0],dis[i][2]));
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值