uva101 - The Blocks Problem

The Block Problem

The Background

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all $0 \leq i < n-1$ as shown in the diagram below:
 
\begin{figure}\centering\setlength{\unitlength}{0.0125in} %\begin{picture}(2......raisebox{0pt}[0pt][0pt]{$\bullet\bullet \bullet$ }}}\end{picture}\end{figure}
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block aretain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output

The output should consist of the final state of the blocks world. Each original block position numbered i ($0 \leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:



解题思路:通过vector< deque<int> >来存储blockWorld,读入blocks个数,初始化blockWorld,通过函数IsTogether判断block是否为相同或在同一堆中,再调用Locate得到block在vector和deque下标的结构体Location,然后读入指令,根据四种指令完成相关动作,直至遇到quit,最后打印并退出
遇到问题:
1.block所在位置未必与vector中的下标一直
2.IsTogether判断条件出错,导致deque::iterator失效,产生runtime error


#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<string>
#include<deque>
using namespace std;

vector< deque<int> > blockWorld;
struct Location
{
	int x;
	int y;
};

bool IsTogether(int a, int b){
	int aNum = -1, bNum = -1;

	for(int i = 0; i < blockWorld.size(); i++){
		for(int j = 0; j < blockWorld[i].size(); j++){
			if(blockWorld[i][j] == a)
				aNum = i;
			if(blockWorld[i][j] == b)
				bNum = i;
		}
		if(aNum >= 0 && aNum == bNum)
			return true;
	}
	return false;
}

Location Locate(int a){
	Location loca;

	for(int i = 0; i < blockWorld.size(); i++){
		for(int j = 0; j < blockWorld[i].size(); j++){
			if(blockWorld[i][j] == a){
				loca.x = i;
				loca.y = j;
			}
		}
	}
	return loca;
}

int main(void){

	int n;
	string moveStr, moveAt;
	int a, b;

#ifndef ONLINE_JUDGE
	freopen("f:\\infile.txt", "r", stdin);
#endif

	while(cin >> n){
		deque<int> temp;
		Location aLoca, bLoca;

		blockWorld.clear();
		for(int i = 0; i < n; i++){
			blockWorld.push_back(temp);
			blockWorld[i].push_front(i);
		}
		while(cin >> moveStr && moveStr != "quit" && cin >> a >> moveAt >> b){
			if(a == b || IsTogether(a, b))
				continue;
			aLoca = Locate(a);
			bLoca = Locate(b);
			if(moveStr == "move"){
				for(int j = aLoca.y + 1; j < blockWorld[aLoca.x].size(); j++){
					blockWorld[blockWorld[aLoca.x][j]].push_front(blockWorld[aLoca.x][j]);
				}
				blockWorld[aLoca.x].erase(blockWorld[aLoca.x].begin()+aLoca.y +1, blockWorld[aLoca.x].end());
				if(moveAt == "onto"){
					for(int k = bLoca.y + 1; k < blockWorld[bLoca.x].size(); k++){
						blockWorld[blockWorld[bLoca.x][k]].push_front(blockWorld[bLoca.x][k]);
					}
					blockWorld[bLoca.x].erase(blockWorld[bLoca.x].begin()+bLoca.y+1, blockWorld[bLoca.x].end());
				}
				blockWorld[bLoca.x].insert(blockWorld[bLoca.x].end(), blockWorld[aLoca.x].begin()+aLoca.y, blockWorld[aLoca.x].end());
				blockWorld[aLoca.x].erase(blockWorld[aLoca.x].begin()+aLoca.y, blockWorld[aLoca.x].end());
			}
			else{//pile
				if(moveAt == "onto"){
					for(int k = bLoca.y + 1; k < blockWorld[bLoca.x].size(); k++){
						blockWorld[blockWorld[bLoca.x][k]].push_front(blockWorld[bLoca.x][k]);
					}
					blockWorld[bLoca.x].erase(blockWorld[bLoca.x].begin()+bLoca.y+1, blockWorld[bLoca.x].end());
				}
				blockWorld[bLoca.x].insert(blockWorld[bLoca.x].end(), blockWorld[aLoca.x].begin()+aLoca.y, blockWorld[aLoca.x].end());
				blockWorld[aLoca.x].erase(blockWorld[aLoca.x].begin()+aLoca.y, blockWorld[aLoca.x].end());							
			}
		}
		for(int j = 0; j < blockWorld.size(); j++){
			cout << j << ":";
			for(int k = 0; k < blockWorld[j].size(); k++){
				cout << " " << blockWorld[j][k]; 
			}
			cout << endl;
		}
	}
	return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值